[vdr] 1.7.12 w/ FF card on old Linux + S2API wrapper

Gavin Hamill gdh at acentral.co.uk
Sun Jan 31 22:01:05 CET 2010


I've been using the same 1.4.7 setup for over 2 years and thought I'd
dip my toe in the 1.7.x world. I'm using Ubuntu dapper (mid 2006) so my
DVB kernel/header setup is still at API level 3, hence I've been using
Udo Richter's S2API wrapper.

Compile was ok, but even trying the simplest setup of "./vdr
-Pdvbsddevice" I'm unable to get a picture or OSD through the FF card.
Is this supposed to work with the S2API patches, or are those purely for
input only?

Jan 31 16:59:01 telly vdr: [10843] VDR version 1.7.12 started
Jan 31 16:59:01 telly vdr: [10843] codeset is 'UTF-8' - known
Jan 31 16:59:01 telly vdr: [10843] found 25 locales in ./locale
Jan 31 16:59:01 telly vdr: [10843] loading
plugin: ./PLUGINS/lib/libvdr-dvbsddevice.so.1.7.12
Jan 31 16:59:01 telly vdr: [10843] loading /video/setup.conf
Jan 31 16:59:01 telly vdr: [10843] loading /video/sources.conf
Jan 31 16:59:01 telly vdr: [10843] loading /video/channels.conf
Jan 31 16:59:01 telly vdr: [10843] loading /video/timers.conf
Jan 31 16:59:01 telly vdr: [10843] loading /video/svdrphosts.conf
Jan 31 16:59:01 telly vdr: [10843] loading /video/remote.conf
Jan 31 16:59:01 telly vdr: [10843] loading /video/keymacros.conf
Jan 31 16:59:01 telly vdr: [10843] ERROR: unknown plugin 'screenshot'
Jan 31 16:59:01 telly vdr: [10843] ERROR: empty key macro
Jan 31 16:59:02 telly vdr: [10843] reading EPG data from /video/epg.data
Jan 31 16:59:02 telly vdr: [10844] video directory scanner thread
started (pid=10843, tid=10844)
Jan 31 16:59:02 telly vdr: [10845] video directory scanner thread
started (pid=10843, tid=10845)
Jan 31 16:59:02 telly vdr: [10844] video directory scanner thread ended
(pid=10843, tid=10844)
Jan 31 16:59:02 telly vdr: [10845] video directory scanner thread ended
(pid=10843, tid=10845)
Jan 31 16:59:03 telly vdr: [10843] probing /dev/dvb/adapter0/frontend0
Jan 31 16:59:03 telly vdr: [10843] creating cDvbDevice
Jan 31 16:59:03 telly vdr: [10843] new device number 1
Jan 31 16:59:03 telly vdr: [10843] frontend 0/0 provides DVB-T
("Conexant CX22702 DVB-T")
Jan 31 16:59:03 telly vdr: [10843] probing /dev/dvb/adapter1/frontend0
Jan 31 16:59:03 telly vdr: [10843] creating cDvbDevice
Jan 31 16:59:03 telly vdr: [10843] new device number 2
Jan 31 16:59:03 telly vdr: [10847] tuner on frontend 0/0 thread started
(pid=10843, tid=10847)
Jan 31 16:59:03 telly vdr: [10848] section handler thread started
(pid=10843, tid=10848)
Jan 31 16:59:03 telly vdr: [10843] frontend 1/0 provides DVB-C ("VLSI
VES1820 DVB-C")
Jan 31 16:59:03 telly vdr: [10843] found 2 DVB devices
Jan 31 16:59:03 telly vdr: [10843] initializing plugin: dvbsddevice
(0.0.3): SD Full Featured DVB device
Jan 31 16:59:03 telly vdr: [10843] setting primary device to 2
Jan 31 16:59:03 telly vdr: [10843] device 2 has no MPEG decoder

Of course, device 2 VLSI VES1820 DVB-C definitely does have an MPEG
decoder? Do I really need to upgrade the OS to use newer VDR?

I tried both the existing dvb-ttpci-01.fw and the new TS-enabled one,
with the same results.

Cheers,
Gavin.


[1] http://www.udo-richter.de/vdr/patches.en.html#dvb-api-wrapper






More information about the vdr mailing list