[vdr] VDRAdmin-AM with UTF-8 support?

Jose Alberto Reguero jareguero at telefonica.net
Sun Mar 14 00:23:24 CET 2010


El Sábado, 13 de Marzo de 2010, Andreas Mair escribió:
> Hi,
> 
> have you tried VDRAdmin-AM v3.6.6? UTF8 handling has been changed there.
> 
> Best regards,
> Andreas
> 

There is still the problem with es_ES.utf8 and es_ES.UTF8. I think that the 
problem is that in the sources in the locale directory there are es_ES.utf8 
instead of es_ES.UTF8.

Jose Alberto

> 2009/3/14 Jose Alberto Reguero <jareguero at telefonica.net>:
> > El Viernes, 13 de Marzo de 2009, H. Langos escribió:
> >> Hi,
> >> 
> >> I just installed vdr and vdradmin-am on Debian lenny and it seems that
> >> two years down the road the problem still exists. (Though in a more
> >> subtle way)
> >> 
> >> I even tried the 3.6.4-1 from debian testing and still the pages have
> >> this in the head section:
> >> 
> >>  meta http-equiv="content-type" content="text/html;charset=ISO-8859-1"
> >> 
> >> My system default locale is en_US.UTF-8
> >> # cat /etc/default/locale
> >> LANG="en_US.UTF-8"
> >> 
> >> Only switching to something like de_DE.UTF-8 seems to fix the problem.
> >> Seems like gettext('ISO-8859-1') is not the best way of handling
> >> encodings after all.
> >> 
> >> Anyway, isn't it time to make a move towards a default UTF-8?
> >> 
> >> cheers
> >> -henrik
> >> 
> >> PS: I'm not subscribed to vdr or vdradmin-am. So please CC me.
> > 
> > In my case the problem is that the directory where the UTF8 locale is
> > stored is:
> > 
> > /usr/share/locale/es_ES.utf8/
> > 
> > if I change to:
> > 
> > /usr/share/locale/es_ES.UTF8
> > 
> > All work ok.
> > 
> > Jose Alberto
> > 
> >> On Thu, Jan 01, 1970 at 12:00:00AM +0000, Jose Alberto Reguero wrote:
> >> > El Mi?rcoles, 28 de Marzo de 2007, Lucian Muresan escribi?:
> >> > > Jose Alberto Reguero wrote:
> >> > > > El Martes, 27 de Marzo de 2007, Harald Milz escribi?:
> >> > > >> Hi,
> >> > > >> 
> >> > > >> is anyone working on a UTF-8 version of VDRadmin-AM? I'm using
> >> > > >> vdr with the UTF8 patch (de and ru) and need to always select
> >> > > >> UTF8 manually in the browser to avoid seeing the ? stuff.
> >> > > >> Looking at the html files in template/default/, I see everything
> >> > > >> is hardcoded in iso-8859-1, but that should be a configuration
> >> > > >> option. Setting LANG=de_DE.utf8 doesn't help, it is silently
> >> > > >> ignored.
> >> > > >> 
> >> > > >> Anyone?
> >> > > >> 
> >> > > >> THX.
> >> > > > 
> >> > > > I run:
> >> > > > 
> >> > > > sed -i -e s/ISO-8859-1/UTF-8/g *.html
> >> > > > 
> >> > > > in the template/default/ directory.
> >> > > 
> >> > > Andreas Mair already adopted my UTF-8 patch for the vdradmin
> >> > > locales, months and versions ago. It patches the makefile and adds
> >> > > targets for generating the UTF-8 locales out of the stock ones. For
> >> > > more info, check this thread:
> >> > > http://www.linuxtv.org/pipermail/vdr/2006-July/010116.html
> >> > > 
> >> > > Regards,
> >> > > Lucian
> >> > 
> >> > I use make.sh utf8add and make.sh po but the html files in
> >> > template/default/ still have references to ISO-8859-1, as Harald Milz
> >> > says, and firefox put the encoding to ISO-8859-1. That is with
> >> > vdradmin-am-3.5.3.
> >> > 
> >> > Jose Alberto
> > 
> > _______________________________________________
> > vdr mailing list
> > vdr at linuxtv.org
> > http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr




More information about the vdr mailing list