<!-- Some styling for better description lists --><style type='text/css'>dt { font-weight: bold;float: left;display:inline;margin-right: 1em} dd { display:block; margin-left: 2em}</style> funman: i.e. lnb->foo means lnb[0].foo <br> https://pastebin.com/iijjyAUA ? mchehab: yeah, that sound about right <br> <u>funman</u>: ^ <br> I would rename lnb -> lnb_array too, in order to avoid similar mistakes <br> good catch! <br> hmm... that won't work... I'll take a look later, when I find some time <br> the logic there is broken... it is using the legacy randeswitch field <br> part of the logic at dvb_sat_get_freq() should be used for dvbsat_diseqc_set_input() and dvb_sat_real_freq() <br> I can't look on it today, but I'll try to fix it tomorrow funman: yes renaming would be a good idea