[linux-dvb] FDSR messages

Manu Abraham manu at kromtek.com
Tue Apr 12 16:18:25 CEST 2005

Hamish Moffatt wrote:
> On Tue, Apr 12, 2005 at 07:21:04PM +0800, David Sobon wrote:
>>On Apr 12, 2005 11:43 AM, Hamish Moffatt <hamish at cloud.net.au> wrote:
>>>See what else you have on the same PCI bus (using lspci). In my case the
>>>on-board SATA controller was on the same PCI bus as the slots, so when I
>>>did much access to a SATA disk I got FBUS errors.
>>How can I tell if it's on the same bus? same irq? Not using SATA here.
> Use lspci. Here's an extract from mine (I have two KWorld CX23883 cards and
> an older Nova-T like card, plus an SBLive and a WLAN card in there).
> 0000:00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
> 0000:00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
> 0000:00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
> 0000:01:06.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)
> 0000:01:06.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 08)
> 0000:01:07.0 Multimedia video controller: Conexant Winfast TV2000 XP (rev 05)
> 0000:01:07.2 Multimedia controller: Conexant: Unknown device 8802 (rev 05)
> 0000:01:08.0 Multimedia video controller: Conexant Winfast TV2000 XP (rev 05)
> 0000:01:08.2 Multimedia controller: Conexant: Unknown device 8802 (rev 05)
> 0000:01:09.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
> 0000:01:0a.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
> 0000:01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
> 0000:01:0d.0 Unknown mass storage controller: Silicon Image, Inc. (formerly CMD Technology Inc) SiI 3112 [SATALink/SATARaid] Serial ATA Controller (rev 02)
> 0000:02:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a4)
> There's three busses here, which is indicated by the second part.
> 0000:00 is all on-board stuff (in the northbridge/southbridge I think); 
> 0000:01 is mostly the PCI slots, but you can see the onboard Gigabit 
> ethernet and the SATA controller are also there. 0000:02 is the AGP bus.
>>I do have an analog card (irq == 18) in there aswell.
> If it's on the same PCI bus (almost certainly the case) that won't be
> helping if you're using it at the same time.
>>>There was no solution except to replace the card with one that used a
>>>better chipset.
>>That's weird. it worked without problem while using the machine
>>interactively on my old dual celeron. maybe the system distributed
>>IRQs between the CPUs and did not hammer the system as much as a
>>single CPU system. Now to wait for dual core processors to solve this
>>problem, heh.
> I don't think it's IRQ related. The card transfers the data into the CPU

Sharing an IRQ, usually with bttv cards shows the same problem you just 

> memory via DMA then indicates that it happened using an interrupt. The
> problem is that it's having to wait too long to get access to the PCI
> bus due to other activity. The IRQs aren't relevant.
> Did your older system have everything else the same, like the analog
> BT878 card?
> Some people say it's gotten worse with recent kernels. They may be
> right. For months I had the Nova-T-like and the Aver761 and it worked.
> The Aver got worse, which I couldn't really explain. When I started using 
> the SATA controller, the Aver became unusable - but that was
> understandable.

That job is supposed to be taken care by the DMA controller... Is DMA 
working in the first case.. ?

>>>The Lite card is cheaper than the FusionHDTV non-Lite because the
>>>chipset is crap for digital TV. Sorry about that.
>>Pity most "reviews" mention there are practically no differences
>>between cards besides the windows software. Now I kind of regret
>>getting the Lite version. Looks like this chipset is the realtek
>>version of tv cards. heh.
> It's designed for analog. The digital TV cards use the audio path to

As per the Fusion docs it is not only for analog, but It _is_ 
specifically meant for digital..
The old Rockwell, nor the Brooktree had this , but the Fusion has this 
feature, looking at the history of the 878.
Not too bad a chip, provided you have a good driver.

> transfer data; it's designed for 44kHz 16-bit stereo at best, which is
> under 2Mbit/sec; the digital card tries to transfer up to 23Mbit/sec
> through it. The buffers just aren't big enough.

That's where PCI latencies play a big role...

> This BT878 thing is a hobby-horse of mine though (having been burnt by
> the Aver761 and spent quite a while trying to find a solution), so feel

I would say that it is a DMA/PCI latency realted problem.. I have not 
seen that problem at all, till now, so can't really help much in solving 
that out.. unless somebody really digs down to the core problem.. It 
would be quite a patience consuming effort..


More information about the linux-dvb mailing list