[linux-dvb] CinergyT2; locked but no data

Petr Nejedly P.Nejedly at sh.cvut.cz
Wed Aug 10 16:55:24 CEST 2005

Bruno Smets wrote:

> Hi,
> Looking for help to solve CinergyT2 problem -> tuner seems to be 
> locked but no data is coming out as endpoint
> seems not to be recognized. Any help is welcome.

Are you sure you connected the T^2 device into a functional USB2.0 port 
(i.e. ehci driver up'n'running)?

I've seen the behaviour you're describing when I tried USB1.1
The device doesn't support USB1.1 much. The Linux driver doesn't send data
over USB1.1 at all, while the windows driver tries to push at least 
radio stations
over USB1.1 (due to insufficient buffering available, it would be hard 
to squeeze
badly MUXed streams into USB1.1 and bulk transfer is out of question 
(64B max packet))

If you plug the device into USB1.1, it offers undocummented ISOC endpoint
instead of BULK one.

> I'm trying to bring-up the CinergyT2 USB DVB-T receiver module within 
> linux-dvb stack. The USB-device had
> firmware version 1.06 which was using isochronous data transfers. The 
> USB descriptors show a strange
> structure, so I've upgraded the device to firmware version 1.08. The 
> descriptor structure seems more logical here and using
> bulk transfers.

I haven't tried official firmware update though....


More information about the linux-dvb mailing list