[linux-dvb] Last rev of skystar-usb, still compatible with linux dvb driver ?

Patrick Boettcher patrick.boettcher at desy.de
Wed Aug 24 12:06:59 CEST 2005

On Wed, 24 Aug 2005, Lavoie.S wrote:

> flexcop skystar-usb in macintosh G4 ppc, any hope ? could be supported in 
> next cvs releases of dvb-kernel driver ? Should i give-up...

As I said, I don't have a real idea how to fix it easily, without changing 
large portions of the driver, for which I don't have the time currently.

> In answer to your last mail, i can tell you that :
> 1-     yes, the mac address in "/var/log/messages" is the correct one;
> 2-     No, unfortunately i didn't get any improvement by replacing in "DVB/ 
> build-2.6/flexcop-reg.h" the line #include "flexcop_ibi_value_be.h" with 
> #include "flexcop_ibi_value_le.h".
> As you didn't specify it and i didn't know what i was doing, i tried first to 
> make the change before compiling the driver, so i removed the old 
> /usr/src/dvb-kernel/ dir replaced it with a fresh new one then :
> # cd /usr/local/src/DVB

So /usr/local/src/DVB is a fresh dvb-kernel checkout, because you are 
talking about /usr/src/dvb-kernel/ above.

> # ./makelinks /usr/src/linux

When you compile and load it in build-2.6 you don't need to run makelinks. 
This is just for linking dvb-kernel into the kernel.

> # cd DVB/build-2.6
> then i edited the file flexcop-reg.h
> # make
> # ./insmod.sh load

Correct. Compiling first is correct.

> pluged the device...no improvement

That is strange. I would have expected it working after that change. Are 
you really sure that you load the correct modules?

> 3-    Also, i tried to use the kernel DVB drivers instead of the CVS linuxTV 
> ones so, i recompiled my custom 2.6.13-rc5 kernel with B2C2 drivers 
> configured as modules, restarted the computer, then :
> # modprobe b2c2-flexcop-usb
> modules loaded correctly without any problem.
> I pluged the device...i got nearly the same messages as before except from 
> one or two line(s) :
> Aug 18 17:10:18 localhost kernel: allocation failed: out of vmalloc space - 
> usevmalloc=<size> to increase size.
> Aug 18 17:10:18 localhost kernel: b2c2-flexcop: dvb_dmx failed: error -12

You are mixing up kernel modules and dvb-kernel modules now. Don't do 


   Mail: patrick.boettcher at desy.de
   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/

More information about the linux-dvb mailing list