[linux-dvb] Pinnacle PCTV 300i: tuner module not supported yet ?

wanderer at netikka.fi wanderer at netikka.fi
Thu Aug 25 16:05:19 CEST 2005


I've tried to get my Pinnacle card to work. This list has other messages
concerning this same driver and I've followed those instructions and tried
kernels 2.6.11 and 2.6.12 with video4linux patches. With 2.6.11 and v4l patch
saa7134-dvb driver isn't loaded, but with 12 it is, so I used that.

Now the board is found correctly, but frontend won't work because mt352 gives
trouble. Is it so that tuner module mt20xx don't support mt2050 tuner yet ?

From /var/log/messages:
kernel: saa7130/34: v4l2 driver version 0.2.14 loaded
kernel: saa7130/34: snapshot date 2005-08-01
kernel: ACPI: PCI interrupt 0000:00:08.0[A] -> GSI 10 (level, low) -> IRQ 10
kernel: saa7133[0]: found at 0000:00:08.0, rev: 208, irq: 10, latency: 32,
mmio: 0xeb101000
kernel: saa7133[0]: subsystem: 11bd:002f, board: Pinnacle PCTV 300i DVB-T +
PAL [card=50,insmod option]
kernel: saa7133[0]: board init: gpio is 600e000
kernel: saa7133[0]: dsp access wait timeout [bit=WRR]
kernel: saa7133[0]: i2c eeprom 00: bd 11 2f 00 54 20 1c 00 43 43 a9 1c 55 d2
b2 92
kernel: saa7133[0]: i2c eeprom 10: ff e0 60 06 ff 20 ff ff 00 30 8d 2c 0f 7e
ff ff
kernel: saa7133[0]: i2c eeprom 20: 01 2c 01 03 03 01 04 31 98 ff 00 a8 ff 21
00 c2
kernel: saa7133[0]: i2c eeprom 30: 96 10 03 32 15 20 ff ff 0c 22 17 77 03 17
fd b6
kernel:  : chip found @ 0x96 (saa7133[0])
kernel: tuner 2-004b: microtune: companycode=8000 part=21 rev=06
kernel: tuner 2-004b: microtune unknown found, not (yet?) supported, sorry
 :-/ kernel: saa7133[0]: registered device video0 [v4l2]
kernel: saa7133[0]: registered device vbi0

And dmesg gives line:
tuner 2-004b: Tuner has no way to set tv freq

Technical data tells that
video decoder is Philips SAA7134 (and board identifies as 7133, well,
 wouldn't count very much on this info).
tv tuner is Microtune MT2050 frequency range 45.75 to 863.25 MHz
Analog demodulator TDA 9885
DVB-T demodulator Zarlink MT352 16,64 QAM, QPSK 6,7,8 MHz bandwith UHF VHF

Am I in trouble or have I simply forgotten something ?


More information about the linux-dvb mailing list