[linux-dvb] twinhan alpha/vp7045 keyboard problem

Patrick Boettcher patrick.boettcher at desy.de
Fri Aug 26 19:28:22 CEST 2005


On Fri, 26 Aug 2005, Martin Ereth wrote:
> I just installed kernel 2.6.13-rc7, in there is the driver for my usb stick 
> "TwinhanDTV alpha". I activated it as a module (dvb_usb_vp7045).
> I installed kaffeine-0.7, it found all channels and I watched TV. Everything 
> works fine.
> [..]
>> vp7045: USB control message 'in' went wrong.
>> vp7045: USB control message 'out' went wrong. (II)
> Moreover a "beep" is audible, because every second (or a half) it is like the 
> tab key is pressed. Together with a beep the message (II) appears.

The driver polls the remote control. When this fails, those messages 
appear. Obviously the remote control poll function does not handle the 
error correctly, so it passes a wrong key to the event-interface. Probably 
the key that produces the beep.

Can you please try the attached patch?

Also you can disable RC polling by loading dvb-usb as follows:

modprobe dvb-usb.ko disable_rc_polling=1

> The stick worked. I closed Kaffeine again and re-plugged the stick. Waited 
> opened Kaffeine: it got stuck.

Please make sure, that you do not plug off the stick, while any DVB 
application is running. (Also wait some seconds before plugging off the 
stick after the application has been closed)

> Is this a problem in the module?
> Does anybody now anything about my problem?
> How stable is the driver vp7045?

For me it worked in a 24h test. But: It is most likely that the device 
consumes more power than allowed by the USB standard. Normally this is no 
problem, because most USB Hosts provide more power than "allowed". Does 
your BIOS has an power to raise the USB power above the standards (mine 
has, but I don't need to activate it for my Alpha). Also, if you are 
running the stick on a laptop while it runs on batteries can be the cause.
Heat can be a problem.

I would recommend you to consider that is a hardware problem rather than a 
driver problem. However, it seems that somehow the device crashes, not in 
software but the hardware.

best regards,

   Mail: patrick.boettcher at desy.de
   WWW:  http://www.wi-bw.tfh-wildau.de/~pboettch/
-------------- next part --------------
Index: linux/drivers/media/dvb/dvb-usb/vp7045.c
RCS file: /cvs/linuxtv/dvb-kernel/linux/drivers/media/dvb/dvb-usb/vp7045.c,v
retrieving revision 1.18
diff -u -3 -p -r1.18 vp7045.c
--- linux/drivers/media/dvb/dvb-usb/vp7045.c	16 Aug 2005 10:35:17 -0000	1.18
+++ linux/drivers/media/dvb/dvb-usb/vp7045.c	26 Aug 2005 17:27:12 -0000
@@ -131,8 +131,11 @@ static struct dvb_usb_rc_key vp7045_rc_k
 static int vp7045_rc_query(struct dvb_usb_device *d, u32 *event, int *state)
 	u8 key;
-	int i;
-	vp7045_usb_op(d,RC_VAL_READ,NULL,0,&key,1,20);
+	int i,ret;
+	if ((ret = vp7045_usb_op(d,RC_VAL_READ,NULL,0,&key,1,20)) < 0) {
+		err("remote control poll failed.");
+		return ret;
+	}
 	deb_rc("remote query key: %x %d\n",key,key);

More information about the linux-dvb mailing list