[linux-dvb] Re: [Patch] Adding support for the Hauppage HVR1100
js at linuxtv.org
Thu Dec 1 18:30:10 CET 2005
On Thu, Dec 01, 2005, Steve Toth wrote:
> Johannes Stezenbach wrote:
> >Hm, it is called enable_plli2c(). Can it be added in a place where
> >we know that the following i2c transaction talks to the PLL?
> >Or do you want to rename it?
> I don't understand, rename it to... what exactly? Something cx22702
> specific you mean?
No. If I understand your code correctly (sorry, I have very little
time and it's likely I misunderstand because I just skimmed
over your code), you use it to open the I2C gate for every i2c
transaction which v4l does, no matter what part v4l is talking to.
The "rename" thing was just to tease you ;-), I still don't get
why you can't use it specifically for the VIDIOC_SET_FREQ ioctl
and nowhere else?
> Maybe the overall approach is wrong. Initially I tried a board specific
> patch, which nobody liked. Then I tried a generic framework patch, which
> people don't appear to like. Is their another way?
Probably you should doubt me and not yourself. When it comes
to v4l internals I'm pretty clueless ;-/
video4linux-list mailing list
Unsubscribe mailto:video4linux-list-request at redhat.com?subject=unsubscribe
More information about the linux-dvb