[linux-dvb] Re: [Patch] Adding support for the Hauppage HVR1100

Steve Toth stoth at hauppauge.com
Thu Dec 1 19:27:09 CET 2005

Johannes Stezenbach wrote:
> On Thu, Dec 01, 2005, Steve Toth wrote:
>> Johannes Stezenbach wrote:
>>> Hm, it is called enable_plli2c(). Can it be added in a place where
>>> we know that the following i2c transaction talks to the PLL?
>>> Or do you want to rename it?
>> Thanks.
>> I don't understand, rename it to...  what exactly? Something cx22702 
>> specific you mean?
> No. If I understand your code correctly (sorry, I have very little
> time and it's likely I misunderstand because I just skimmed
> over your code), you use it to open the I2C gate for every i2c
> transaction which v4l does, no matter what part v4l is talking to.
> The "rename" thing was just to tease you ;-), I still don't get
> why you can't use it specifically for the VIDIOC_SET_FREQ ioctl
> and nowhere else?
The gate is opened by atleast three (maybe four) different ioctls and 
three non-ioctl related functions that deal with the IF demod inside the 
PLL.Anything that modified the PLL needs access and anything that 
touched the tda9887 needs access.

Two I2C devices live behind the gate. Sorry if I did not make this clear 

It's used in atleast six places and I have not looked at any possible 
cx88-tvaudio or cx88-alsa (future) implications. I have a feeling it 
could be as high as 10-15 places.

If it was just one place I would of done that a few days ago and this 
would all be over.


More information about the linux-dvb mailing list