[linux-dvb] Cinergy T2 freezes System on rmmod

Johannes Stezenbach js at linuxtv.org
Mon Dec 19 16:29:15 CET 2005

On Mon, Dec 19, 2005, Stephen Williams wrote:
> On 12/19/05, Patrick Fischer <patrick_fischer at gmx.de> wrote:
> > I have two Cinergy T2 USB DVB-T on my Laptop just to develop Plugins for
> > VDR.
> > I works find, but sometimes I have some Problems.
> >
> > I restart up to 20-30 Times a day my VDR and each time VDR tunes to a
> > channel.
> > After awhile the first T2 don't stop shine the LED if I stop VDR. After
> > awhile the other seems to freeze. Both LED's shine. So I can't use them
> > anymore. It's ugly but not very awful if I could do something.
> > If I try to remove the modul by rmmod, then my whole System freeze. If I
> > try to pull out the usb device the system freeze to.
> >
> > I'm using debian sarge with and the driver from Kernel.
> > I have tried the Kernel but with still the same bug.
> There have recently been patches to the CVS driver that could have
> fixed this issue. I don't think those changes have made it into any
> kernel release yet. Could only suggest trying CVS and see if that
> helps.

An attempt to fix Oops on rmmod when the cinergyT2 is still in
use has been in CVS for a while and has recently sent to Linus.

However, the issue that the Cinergy stops working is new to me.
Are there any USB error messages in dmesg when this happens?
If not, could you try SysRq-T and check if a kernel thread related
to USB or DVB hangs somewhere?
Maybe your laptop's USB power supply isn't good enough? I have
occational used one CinergyT2 on my laptop and it worked fine.


More information about the linux-dvb mailing list