[linux-dvb] TwinHan 1030a Adapter

Christiaan Brand christiaan at uitsiglan.co.za
Sat Jul 2 16:13:45 CEST 2005

Hi everyone,


I've been searching through archives on the internet for the past two days,
and have only found one other mention of someone who had EXACTLY the same
problem that I'm having. To my knowledge his problem isn't solved yet


I have a P-III computer with Fedora Core 3 installed (also tried it with
FC2) and a TwinHan 1030a adapter. When loading the drivers, the following
two lines behave exactly as expected:

modprobe bttv i2c_hw=1 card=0x71
modprobe dvb-bt8xx


dmesg reports the card as detected and everything else seems normal.


As soon as I try to load the frontend driver, by using:

modprobe dst


I only see the following text:

bt878 find by dvb adap: checking "DST"


This just returns me to my prompt, and NO front end is ever registered.


I tried the line (modprobe dst) with verbose and debug enabled, and it
yielded the following:


write_dst: write_dst error (err == -5, len == 0x08, b0 == 0x00)


This gets written out 5 times, and the last line I see, is:


dst_check_ci: write not successful, maybe no card?


I desperately want to get the card working with MythTV, so any help would be
very much appreciated.




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20050702/9771ae67/attachment.htm

More information about the linux-dvb mailing list