[linux-dvb] Re: both 8VSB and QAM256 working on DViCO FusionHDTV 3 Gold-T

Michael Krufky mkrufky at m1k.net
Sat Jul 9 14:08:20 CEST 2005

Mac Michaels wrote:

>On Friday 08 July 2005 04:55 pm, Michael Krufky wrote:
>>Mac Michaels wrote:
>>>On Thursday 07 July 2005 11:46 am, Michael Krufky wrote:
>>>>Mac Michaels wrote:
>>>>>On Wednesday 06 July 2005 11:30 pm, Michael Krufky wrote:
>>>>>>After applying the read status fix and using
>>>>>>us-Cable-Standard-center-frequencies-QAM256, I got
>>>>>>the attached output from atscscan. Then I ran
>>>>>>mplayer and got beautiful HD video.  SD worked even
>>>>>>better.  :-)
>>>>>>dumping lists (256 services)
>>>>>Great! It was worth the time it took to create the
>>>>>center frequency lists :-)
>>>>>-- Mac
>>>>For some reason, I'm not always getting good results
>>>>like I did last night.  When I first ran that test
>>>>last night, I got the 256 locks as stated above. 
>>>>After rebooting, I got status 0x00 across the board,
>>>>and after rebooting again, I got all the locks again. 
>>>>I suspect that there is another factor here that I
>>>>must be overlooking...
>>>This is ugly. Intermittent problems are usually very
>>>hard to find.
>>It seems to work more often from a cold boot... I've also
>>noticed the following.... I have been having intermittent
>>problems with my ps/2 mouse, regardless of what kernel I
>>am running, but have NO mouse problems in windows.  When
>>the ps/2 mouse isnt working, I just use my usb mouse
>>instead.  Anyhow, I have noticed that when the ps/2 mouse
>>doesn't work, DVB doesn't work either.  The module loads
>>up and everything seems correct, but I just cant get a
>>lock.... In these cases, I will always get status code
>This means the tuner is not seeing any signal at all. On 
>cable I would expect to see at least a 0x01 on almost every 
When I run atscscan, I can hear the tvaudio coming from my pc speakers 
while it is scanning... On the lower frequencies, I can hear full audio 
of the channel that is currently tuned, although i still get 0x00 (this 
is what happens when atscscan tunes to an analog channel?)  When it 
actuallt gets a digital lock, I dont hear any sound in the speakers.  
(the audio is encoded in the mpeg ts, so no analog sound comes from the 
pc speakers) .....

This behavior doesn't surprise me, but I thought I'd mention it just in 

>You probably have a hardware problem on the motherboard.
>>The HD streams seem to be more volitile than the SD
>>streams.  I haven't had a HD stream last for much longer
>>than a minute or so, but I've had SD stream last for as
>>long as 20 minutes.
>I"ll bet the something is heating up, probably the processor 
>or power supply. HD is a bigger strain than SD on the 
>processor. Mor success with coldboot also indicates 
>processor heat problem. Is the heatsink installed properly 
>with conductive grease? Fans slow or clogged with dust? 
>Overclocking? The list goes on...

I don't think that I have a physical hardware problem on my motherboard 
-- I only have these problems in linux -- not in windows.  I am NOT over 
clocking.  The hardware that I'm using is all less than 8 months old.  I 
am using a Shuttle ST61G4 machine.  (this box is tiny, and has extremely 
efficient cooling mechanisms. 3.06 GHz 533 bus, hyper-threading.... 1024 
DDR2 400 mhz ram ...  Using Radeon 9100 IGP.  Maxtor SATA hard disk 
(irrelevant).  There is nothing else connected to this machine besides 
what comes built-in to the FT61 mainboard, some usb stuff, and a 
CF-to-IDE adapter.

Also, I should have mentioned, I said that sometimes a cold boot helps 
-- Once I get a lock during a session, I have no trouble getting digital 
locks on any channel up until my next reboot.  I really think this could 
be caused by some bug in the kernel that I haven't had the chance yet to 
figure out.  I have never seen this problem using the gentoo stock 
2.6.11-r9 kernel, up until I started using video4linux cvs (without 
lgdt3302 driver) .... I don't use 2.6.11 any more.  I do have this 
problem when using the mainline kernel series 2.6.12 and on, and I also 
have these problems in -mm.

If the bug is coming from video4linux cvs, then I'm sure we will be 
alerted by some bug reports soon, since Mauro just sent the final 
updates over to lkml, containing all the latest v4l code.

Any time that I boot the machine up into windows, all of these problems 
go away.

I think the bug is somehow in relation to initialization of some 
memory/register/something-or-other.  The bug MIGHT be in lgdt3302 code, 
or it might be elsewhere.  Nothing explains my ps/2 mouse problems.

I should also mention, there were a few times where I couldn't get a 
lock using azap, then I ran atscscan for a few seconds, tried azap 
again, and got a lock.

I really need to pick up another hard drive, or set aside a new 
partition, and install debian sarge on it.  For all I know my problems 
can be because of some gentoo quirk.

>>>>Also, what would be involved with fixing ber and signal strength?
>>>I can do that. Do you have any idea what units are expected for ber?
>>I don't know anything about this.... (ber)  Maybe someone reading the list will respond with some info....
Michael Krufky

More information about the linux-dvb mailing list