[linux-dvb] [eb2a:17de] V-Stream XPERT DTV DVB-T USB 2.0

James Le Cuirot chewi at ffaura.com
Wed Jul 13 02:48:10 CEST 2005

Okay I promise this isn't as useless as my last issue!

I finally got a device that actually IS a DVB device and not some other
thing with a similar sounding name. It's the V-Stream XPERT DTV DVB-T
USB 2.0. The dvb-dibusb driver didn't pick it up though. I checked the
USB ID and it didn't match any that the driver recognised. I tinkered
with the driver a bit myself (not done that before) and after a couple
of attempts, I managed to get it to work. eb2a:17de is the ID it has
during the "cold" state. After uploading the firmware, it switches to
the "warm" state with an ID of 06e1:a334, which the driver does
recognise. I used the DIBUSB2_0B part of the driver and it consequently
asked for the dvb-dibusb-adstech-usb2-1.fw firmware file. This is
missing from http://www.linuxtv.org/downloads/firmware/ but I did
find dvb-usb-adstech-usb2-02.fw in the CVS repository and that worked.

I say "worked" in a loose sense because I then discovered that
terrestrial digital TV is not available where I live. Gah! I had
wrongly assumed that it was available across the whole of the UK. I
would have at least thought that it would be available here. Nevermind.
dmesg showed no errors, the device lit up, the device nodes appeared
in /dev/dvb and I was able to run scan - though obviously I couldn't
pick anything up. I think we can assume that it would have actually


More information about the linux-dvb mailing list