[linux-dvb] bt878(0): IRQ lockup, cleared int mask

Jukka Tastula jukka.tastula at kotinet.com
Sun Jul 31 05:05:49 CEST 2005

On Sunday 31 July 2005 00:17, David Johnson wrote:
> As I'm watching TV, I'm getting lots of the following messages in demsg:
> bt878(0): irq FDSR FBUS risc_pc=1fc66010
> bt878(0): irq FBUS risc_pc=1fc66158
> bt878(0): IRQ lockup, cleared int mask

I had exact same problem for a very long time with my nxt6000 nebula. I 
finally some weeks ago tracked it down to the nic I was using (rtl8139). 

These errors would appear when data was moving over the network. It seemed 
completely random at first but became apparent when I started using nfs 
for vdr recording storage; fast forwarding would always trigger it 
instantly. The dvb card apparently also completely stopped transferring 
data while these errors happened so I'd have unexplained gaps in my 

I still don't understand why it dislikes the nic as the other dvb-t card I 
have (also bt878 based) doesn't seem to bork like the nebula does.

For now I'm using the onboard nic, via rhineII. Not really the perfect 
trade as the driver is utter crap. Keeps resetting itself all the time so 
bad that the average maximum bandwidth comes out to about 4MB/s, but at 
least the nebula doesn't keep losing irqs anymore and my recordings don't 
have gaps in them.

Tried with two different motherboards, the nebula just doesn't seem to like 
to play well with others. I tried all kinds of latency tricks on the nic 
and both dvb cards. Nothing less than throwing away the nic "cured" it.

More information about the linux-dvb mailing list