[linux-dvb] dvbtune

Riviere Informatique SARL svdbeek at rivinfo.com
Thu May 26 22:35:41 CEST 2005


Hi again,

Thanks to all who replied.
When looking around some more I found a quick and very very easy 
solution: kaffeine.
Kaffeine didn't display the DVB option at first. Only when I ran it as 
root. That's probably just a permissions issue.
It will automatically scan the whole satellite and it plays right away. 
And you can record with it too. Not yet tried, though.

Regards,
Steven.

--- Original message ---
Hi all,

I'm new to this group and I've got a few problems.

It took me quite some time to make my SAA1746 card (Hauppauge Nexus-S) 
work and be recognized a bit, because I had all the driver software 
installed in the kernel. That didn't work. Once I moved it to modules it 
worked. Sort of.

I can get to a free-to-air channel, which I use for testing, when using 
dvbtune and xawtv. I can see the channel (Though I have no sound, but 
that's not so important for now).
However, the channel turns black after a few seconds. When I relaunch 
dvbtume with the same parameters I get an image again.
Any ideas on what's going on here? The channel is NOT encrypted.

Second problem: How can I scan for channels and build a channel list? 
scantv doesn't work. If ends with the following display:
[defaults]
input = Television
norm = PAL

device has no tuner, exiting

But the default input is DVB, not 'Television' as per:
# v4lctl list
attribute  | type   | current | default | comment
-----------+--------+---------+---------+------------------------------------- 

norm       | choice | PAL     | PAL     | PAL NTSC
input      | choice | DVB     | DVB     | DVB
bright     | int    |     128 |     128 | range is 0 => 255
contrast   | int    |      64 |      64 | range is 0 => 127
color      | int    |      64 |      64 | range is 0 => 127
Horizontal | bool   | off     | off     |
Vertical f | bool   | off     | off     |

I read I could use 'vdr' to scan channels, somewhere, so I tried to 
start 'vdr' and I get the following.
$ vdr
vdr: no primary device found - using first device!

There's only 1 device - yet the error value = 2, so there's some problem.


I've come some way on my own, but hopefully someone can help me along a 
bit more, to fix some of the problems. Or at least point me to the right 
document that can help out.

Thanks,
Steven.





More information about the linux-dvb mailing list