[linux-dvb] KNC1 DVB-S unter openSUSE 10.0

Oliver Endriss o.endriss at gmx.de
Thu Nov 3 02:53:32 CET 2005

Chris Dietrich wrote:
> I downloaded and compiled the latest stable kernel 2.6.14 which includes
> AFAIK newer dvb drivers. Unfortunately I still get exactly the same error.
> > Am Donnerstag, 27. Oktober 2005 16:53 schrieb Chris Dietrich:
> >>Oct 19 19:08:37 linux kernel: saa7146: found saa7146 @ mem d0fa6c00
> >>(revision 1, irq 9) (0x1131,0x4f56).
> >>Nov 02 19:08:37 linux kernel: DVB: registering new adapter (KNC1 DVB-S).
> >>Nov 02 19:08:37 linux kernel: adapter failed MAC signature check
> >>Nov 02 19:08:37 linux kernel: encoded MAC from EEPROM was
> >>ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff
> >>Nov 02 19:08:37 linux kernel: budget-av: ci interface initialised.
> >>Nov 02 19:08:37 linux kernel: KNC1-0: MAC addr = 00:09:d6:40:XX:XX
> >>Nov 02 19:08:37 linux kernel: budget-av: A frontend driver was not
> >> found for device 1131/7146 subsystem 1131/4f56
> Please, anyone got an idea what else I could try to get that card to work?

[I'm not sure whether this card has ever worked reliably with the driver.]
Someone has to find out why stv0299_attach() fails for this card.

> Julian Scheel wrote:
> > I get this error from time to time, too (using gentoo and linuxtv-cvs from a 
> > few weeks ago). Since they usually only occur after using the card very much 
> > before, I thought it should be some thermical problem with the card itself.
> > But this looks like it would be a real software problem...
> > 
> > Maybe an idea from one of the devs?

Add some printk's to stv0299_attach(stv0299.c) and find out what
happens. Sorry, I don't own this type of card.


VDR Remote Plugin available at

More information about the linux-dvb mailing list