[linux-dvb] Old style Nova-T card woes

stuart at dontuse.ms stuart at dontuse.ms
Fri Nov 4 10:11:59 CET 2005

> [quoting rearranged]
> I demand that Stuart may or may not have written...
>> Darren Salt wrote:
>>> I demand that stuart at dontuse.ms may or may not have written...
>>>> Im have trouble getting an old style hauppage nova-t recognised by the
>>>> saa7146 driver. The chips on the site are tda10045 and saa7146. The
>>>> problem seems to be that there is no subsystem id.
>>>> output of lspci -vv is
>>>> 04:0b.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
>>>>         Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
> [snip; IRQ 201]
>>> What happens if you load budget_ci and tda1004x?
>> Ok budget-ci says nothing
>> saa7146: register extension 'budget_ci dvb'.
>> saa7146: register extension 'Multimedia eXtension Board'.
>> saa7146: found saa7146 @ mem f901e000 (revision 1, irq 201)
>> (0x0000,0x0000).
>> *mxb: did not find all i2c devices. aborting*
>> Notice the mxb line, thats new.
> I see *two* lines that I wouldn't expect there - and we have subsystem
> information in the third line...
> That said, a quick grep of the relevant source shows three drivers which
> are
> for SAA7146 cards with subsystem ID 0000:0000 - mxb (which you've just
> seen),
> hexium_orion, and dpc7146.

Rite, a modprobe of saa7146 gives
saa7146: register extension 'dpc7146 demonstration board'.
saa7146: found saa7146 @ mem f8cf0000 (revision 1, irq 201) (0x0000,0x0000).

A modprobe of mbx gives
saa7146: register extension 'Multimedia eXtension Board'.
saa7146: found saa7146 @ mem f8cfe000 (revision 1, irq 201) (0x0000,0x0000).
mxb: did not find all i2c devices. aborting

And a modprobe of hexium_orion gives
FATAL: Error inserting hexium_orion
(/lib/modules/2.6.14/kernel/drivers/media/video/hexium_orion.ko): No such
saa7146: register extension 'hexium HV-PCI6/Orion'.
kobject_register failed for hexium HV-PCI6/Orion (-13)
 [<c029a60c>] kobject_register+0x67/0x75
 [<c02fd3b2>] bus_add_driver+0x75/0xec
 [<c02ab240>] pci_register_driver+0x7e/0x94
 [<f8cfe00f>] hexium_init_module+0xf/0x5a [hexium_orion]
 [<c013ab00>] sys_init_module+0x16f/0x239
 [<c0102e8f>] sysenter_past_esp+0x54/0x75

> I expect that none of those will work, though.
>> Ive put a second saa7146 based nova-t in and it gives me
>> 04:0a.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
>>         Subsystem: Technotrend Systemtechnik GmbH Technotrend-Budget /
>> Hauppauge WinTV-NOVA-T DVB card
> [snip]
> Presumably, _that_ one's working properly.
>> The first nova-t gives
> [snip; still no subsystem info]
>>>> Kernel is 2.6.14.
>>> Is there any difference with 2.6.13.x?
>> I also tried 2.6.13 kernel, same thing. I've also tried moving to
>> different
>> pci slots, one card only etc. everything i do gives the same result, no
>> subsystem id.
> Unless somebody else has a better idea, I'm inclined to say "broken card"
> :-|
> --
> | Darren Salt | d youmustbejoking,demon,co,uk | nr. Ashington,
> | Debian,     | s zap,tartarus,org            | Northumberland
> | RISC OS     | @                             | Toon Army
> |   <URL:http://www.youmustbejoking.demon.co.uk/> (PGP 2.6, GPG keys)
> How sharper than a hound's tooth it is to have a thankless serpent.
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

I did some more digging lastnight and i seems that the card doesnt have an
eeprom hence to subsystem id.

I dont think its "broken" as in faulty but maybe broken from a linux point
of view. Looks like its back to ebay :)



More information about the linux-dvb mailing list