[linux-dvb] NOVA-S only working with HZ=1000

Maximilian Engelhardt maxi at daemonizer.de
Sun Nov 6 16:47:43 CET 2005

On So, 2005-11-06 at 15:34 +0100, Oliver Endriss wrote:
> Maximilian Engelhardt wrote:
> > I have a NOVA-S that was running just fine with all kernels <=2.6.12.
> > Starting with 2.6.13 it suddenly stopped working. Since it still didn't
> > work with 2.6.14, I was wondering why and finally found out that that is
> > was because of the HZ value change (my default HZ is now 250).
> > 
> > The error messages every app I tried on an HZ!=1000 kernel reports is
> > something about TUNING FAILED.
> > 
> > I talked to Bertl on #linuxtv and he suggested me some changes [1], but
> > they didn't help. I also created some debug output from stv0299 with a
> > HZ=250, HZ=250 + patch and a HZ=1000 (=working) kernel. [2]
> You are using DiSEqC.
> Does it help if you change
> 	.flags = 0,
> to
> 	.flags = SAA7146_I2C_SHORT_DELAY,
> in "static struct saa7146_extension budget_extension" (budget-ci.c)?

Thanks for the patch, but it's only a partial success.
I did some tests with your change and the other patch and without the
other patch. (should I keep the stv0299.c patch applied or not?)
Both times I get the same result. I can do a dvbscan on both satellites,
get a channels.conf for both and as far as I can see both look good to
me. But I can only watch TV on the first satellite (Astra). When I try
to watch a program on the second (Hotbird) I still get the tuning failed
error message.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://www.linuxtv.org/pipermail/linux-dvb/attachments/20051106/442980b7/attachment.pgp

More information about the linux-dvb mailing list