[linux-dvb] dishnetwork support not working with skystar-2

Oliver Endriss o.endriss at gmx.de
Sun Nov 13 01:54:05 CET 2005

[I'm forwarding this request since Jeremy Hall is unable
 to access the list atm]

Jeremy Hall wrote:
> Hi, I tried this patch for the lnbp21-based card (the rev2.3) and it
> seems to be working on my rt kernel. (that's better than not working at
> all so I'd say go ahead and check it in.) and this is what I had tried
> with the flexcop version and that failed.  Can you put up a request on
> the linux-dvb list for who wrote the voltage code for the flexcop to ask
> them to check it?

Basically the flexcop driver must be patched to set 
    fc->fe->ops->dishnetwork_send_legacy_command = NULL;
like I did for the saa7146 cards. But it still doesn't work.

driver log:
| b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
| flexcop-pci: will use the HW PID filter.
| flexcop-pci: card revision 2
| DVB: registering new adapter (FlexCop Digital TV device).
| b2c2-flexcop: MAC address = 00:d0:d7:0d:8a:8e
| b2c2-flexcop: found the stv0299 at i2c address: 0x68
| DVB: registering frontend 0 (ST STV0299 DVB-S)...
| b2c2-flexcop: initialization of 'Sky2PC/SkyStar 2 DVB-S' at the 'PCI' bus controlled by a 'FlexCopIIb' complete

Any ideas what could be wrong? A timing problem?


VDR Remote Plugin available at

More information about the linux-dvb mailing list