[linux-dvb] [PATCH] Moving ALPS BSRV2 tuner handling code to separate file.

Oliver Endriss o.endriss at gmx.de
Sat Apr 15 13:18:09 CEST 2006

Michael Krufky wrote:
> Andreas Oberritter wrote:
> >Michael Krufky wrote:
> >  
> >
> >>I think that this was a good idea, although the same exact thing could
> >>be done for all of the other drivers, potentially leading to the
> >>creation of many many more modules just for handling pll's ...
> >>    
> >>
> >It's not just about PLLs, different frontend modules can require
> >different register settings for symbol rate and other stuff even if they
> >use the same demod chip.
> >
> >I like this patch and I think it should be applied. It is a disadvantage
> >to have all the code and arrays duplicated in several drivers if we
> >could have it at a single place.
> >
> >>I would much rather see the pll definition moved into dvb-pll, and the
> >>pll_set function altered to use dvb_pll_configure.
> >>    
> >>
> >The code can still be changed to use dvb-pll afterwards without
> >unnecessary code duplication.
> >  
> >
> I can agree to that.  The same can be done for lg-h06xf, and many 
> others.  A lot of duplicated code could be removed, and I do agree that 
> this would be a step forward.  The only problem I see with this is that 
> we'll end up with many tiny little header files just like this one, 
> bsbe1.h and bsru6.h  ...  This isn't necessarily a bad thing either.  I 
> just didn't know if this is what we wanted to be doing. 

Well, when we started with bsbe1.h and bsru6.h the patches were posted
on this mailing list. Nobody complained...

> Would it make  
> sense to consolidate these small files into single source.[ch] files?  
> What do you think?

I don't like big files which contain lots of definitions which are not
needed by most drivers. That's why I'm not very happy with dvb_pll.c.

When editing a file there is always a small chance to introduce a random
bug somewhere in the file. In theory we have to re-test a driver
whenever we change a file which the driver depends on...

Small files will only affect those drivers which really need them.

I vote for one header file per tuner. It's both easier to maintain and
easier to understand for newbies. If you prefer we can move these files
to a subdirectory to keep them separate from the frontend drivers.

Later these definitions can be converted to use dvb_pll or whatever.
For now they save us hundreds of lines of duplicated code.

Imho this process should be continued step by step for all duplicated
tuner descriptions.


VDR Remote Plugin available at

More information about the linux-dvb mailing list