[linux-dvb] [PATCH] Moving ALPS BSRV2 tuner handling code to
abraham.manu at gmail.com
Sat Apr 15 21:16:20 CEST 2006
Andreas Oberritter wrote:
> Michael Krufky wrote:
>> Andreas Oberritter wrote:
>>> Michael Krufky wrote:
>>>> I would much rather see the pll definition moved into dvb-pll, and the
>>>> pll_set function altered to use dvb_pll_configure.
>>> The code can still be changed to use dvb-pll afterwards without
>>> unnecessary code duplication.
>> I can agree to that. The same can be done for lg-h06xf, and many
>> others. A lot of duplicated code could be removed, and I do agree that
>> this would be a step forward. The only problem I see with this is that
>> we'll end up with many tiny little header files just like this one,
>> bsbe1.h and bsru6.h ... This isn't necessarily a bad thing either. I
>> just didn't know if this is what we wanted to be doing. Would it make
>> sense to consolidate these small files into single source.[ch] files?
> I like small independent files.
> Btw. such a change has been proposed by me last summer and Johannes
> suggested using a common prefix like "fe-" although I'd vote for using
generally, the demod is called a NIM, and the entire tuner is called the
I think the "fe_" sounds more appropriate.
More information about the linux-dvb