[linux-dvb] KNC-1+Cineview CAM+Tuning Problems

Manfred Petz pm at deuromedia.at
Thu Apr 20 14:09:44 CEST 2006

On Wed, 19 Apr 2006, Andrew de Quincey wrote:

| On Tuesday 18 April 2006 12:28, Manfred Petz wrote:
| > hello,
| This is likely caused because on the KNC1 cards, the reset line of the CAM is 
| hooked to the same line as the demodulator reset... so when you reset the CAM 
| (as you have to do), the demodulator gets zapped as well. This caused 
| problems with the tda10046 demodulators, so I added code to reinitialise the 
| demodulator when the CAM was reset.


what you mention makes sense, as i experienced a problem, when i tuned first 
and afterwards doing ioctl (cadev, CA_RESET, slot). this works on hauppauge 
win-tv nova/nexus, which apparently have a different wiring. by resetting 
the CAM before, then waiting 10 seconds, i get no tuning problems anymore

however, it seems that after doing the CA_RESET, tuning works only, if i wait
those 10 seconds. if i tune after 2-3 seconds, i get a lower signal/SNR and a 
high BER:

	status 01 | signal b849 | snr 999c | ber 00003536 | unc 00000000 |
	status 01 | signal b6ee | snr 99b4 | ber 000036c7 | unc 00000000 |

then, it seems, after i wait some time, and then try to tune again, it also 
works. this is quite reproducible:

	zapping to 483 'ZDF':
	sat 0, frequency = 11953 MHz H, symbolrate 27500000, vpid = 0x006e, apid = 0x0078
	using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
	FE_SET_TONE failed: Connection timed out
	FE_SET_VOLTAGE failed: Remote I/O error
	FE_DISEQC_SEND_MASTER_CMD failed: Connection timed out
	FE_DISEQC_SEND_BURST failed: Connection timed out
	status 03 | signal 7c4c | snr 7ad6 | ber 00001608 | unc 00000000 |
	status 1f | signal ba3d | snr c4b9 | ber 00001100 | unc 00000000 | FE_HAS_LOCK

| Perhaps this isn't necessary for the stv0299 cards. Can you try the attached 
| patch (against latest hg) and let me know if it helps with this?

done & things seem to run here well. attached to a Technisat Gigaswitch 11/20G
DiSEqC. we'll test with various other DiSEqC/DVB driver combinations within the 
next few days/weeks.

and i did some more testing with your patch applied to the latest hg and CAM

* when i read data from the DVR device, and remove the CAM and replug it quickly (within 2s), i 
  do not get messages like 'budget_av: cam ejected / cam inserted'. and with a 
  small interruption (1-2s) i get data again from the DVR device (tried about 50 times). no
  problem whatsoever.

* when i read data from the DVR device, remove the CAM and wait until i get 'budget_av: cam ejected',
  then i get no data from the DVR for around 3-5s and then i get data again. however, when i
  replug the CAM, and get 'cam inserted', i do not get data anymore. in no case.

  normally, i get:

  	budget-av: cam ejected
  	budget-av: cam inserted
  	dvb_ca adapter 0: DVB CAM detected and initialised successfully

  rarely i get:

  	budget-av: cam ejected
  	budget-av: cam inserted
  	dvb_ca adapter 0: Invalid PC card inserted :(

  also rarely (when re-plugging):

	dvb_ca adapter 0: CAM tried to send a buffer larger than the link buffer size (65535 > 128)!
	dvb_ca adapter 0: CAM tried to send a buffer larger than the ecount size!
	dvb_ca adapter 0: DVB CAM link initialisation failed :(


| How is your switch controlled (is it DISEQC)? The problem is when the stv0299 
| gets reinitialised, it'll drop the LNB voltage and tone signalling. I did add 
| code to set the simple tone/voltage signalling post-reset, but perhaps it is 
| not working right. I can't really resend DISEQC again (if thats what its 
| using) because that could potentially contain anything.

here it works fine now.

| > 2nd problem:
| >
| >    i can decrypt only one channel at once (it is definitely not a CAM
| > initialization problem). though, i know that the cryptoworks can decrypt at
| > least 3 channels at the same time (and the streaming software can also). i
| > am doing this with some other servers (but with wintv cards).
| This I can't really help with - if you can talk to the cam at all and decrypt 
| a channel, the CI interface is working correctly as far as I know.

sorry for bothering - this was an internal problem, one of our CAM cards was
not registered... arghhhhh.

thanks a lot

More information about the linux-dvb mailing list