[linux-dvb] DVB card remote control geneates too many signals

aabb aabb at chadbournes.f2s.com
Sat Aug 5 02:25:26 CEST 2006

For the benefit of others with a similar problem, who might stumble 
across this post, this is how I fixed it. I'm sure there are much better 
ways, but this worked for me.

The culprit was the bttv module. From kernel 2.6.16, this module has a 
new source file, "bttv-input.c" (it's in directory 
"drivers/media/video/", of the kernel source), which defines the 
infrared codes for various cards. To stop the codes being recognised, 
all I had to do was to pretend that my DVB card doesn't have an IR 
sensor. To do this I edited another source file, "bttv-cards.c", by 
changing ".has_remote = 1" to ".has_remote = 0". This assignment appears 
for each card with a remote and you need to find the one for your card. 

I then just executed the following commands as root:

cd /usr/src/linux
make modules
make modules_install

It should all work properly (i.e. all remote signals intercepted only by 
lircd) after the next re-boot (or just re-loading the bttv module should 
do it).

I'm sure there's a better way that doesn't involve editing source code 
(e.g. with an appropriate configuration option), but as I only update my 
kernel a couple of times a year, and the above only takes  a couple of 
minutes, I'll live with this for now.


aabb wrote:

> Thanks Craig, this sounds promising. Can you explain what you mean by 
> "just used the correct dev/input driver for my card"? I tried setting 
> the LIRCD_OPTS variable to "-d /dev/lirc/0" (in file 
> /etc/conf.d/lircd) but this still didn't work.
> btw, I now believe that the module responsible for detecting the 
> additional signals is bttv (thanks to Peter Fern for pointing me in 
> the right direction).
> Alex
>>> Now it seams that there are 2 separate modules that are responding 
>>> to key presses on the remote, lircd and one other. If I stop lircd, 
>>> the system still responds to the remote
>> I have seen this with my Dvico Dual Digital Card / remote as well.
>> Using 2.6.16, the four purple buttons work, but nothing else on it does.
>> I thought lirc was partialy working, but it turns out even if lirc is 
>> not
>> running the four buttons still work.
>> I eventually got lirc fully working.  Did not change anything else, just
>> used the correct "dev/input" drivers for my card.
>> Craig
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

More information about the linux-dvb mailing list