[linux-dvb] FusionHDTV Dual Digital zl10353 / dee1601 tuning

Damien Dusha damiendusha at netspace.net.au
Sun Aug 20 14:04:23 CEST 2006

Hi Brett (and others still following this saga),

There's something funny going on with the DViCO dual digital.

I had another go at installing Chris's test branch and got the same 
errors I have been getting for a while over a range of kernels and a 
full re-install of FC5:

found 177 modules
ERROR: bad dependencies - dst ( dst_ca )
ERROR: bad dependencies - dst_ca ( dst )
make[1]: Leaving directory `/root/Installs/v4l-dvb-test/v4l'
(My kernel is 2.6.17-9)

Despite this, if I install the files (make install), then they seem to 
work ok, despite this error.

Now reboot....

My observations so far....
 From previous posts by me:

1) The patches the mainline d4l-dvb which were made my Chris, still 
require the 166667Hz offset to Channels 9 and SBS when using the 
channels.conf file supplied by Chris for Brisbane.   SBS is stronlgly 
inconsistant.  On -a0 is never tunes consistantly, but occasinally gains 
a short lock (see below).   On -a1, it has (on occasion) worked, but 
most of the time exhibits the same behavior.

2) Now, I'm following some of the advice offered by various people:
  - Push ahead and install Chris's test branch, despite the errors. (see 
results above)
  - Create my own channels.conf file.  See it at http://pastebin.ca/140314

On the latter, I created my own channels.conf file with scan, starting 
with the au-Brisbane file which I pulled from the dvb-utils hg sources.

Interestingly, there seems to be some different PIDs for some of the 
channels (not SBS), I'm curious as to whether this is significant.

The results of this were:
  - The offset problem for Channel 9 has been solved.  It now works 
without adding a 166667Hz offset to the frequency.
  - SBS still refuses to tune, with and without the +-166667Hz offset.

I have attached some of the output for tzap below:
  - Tuner 0: It consistant has some SNR followed by a brief lock period, 
then conpletely drops out.
  - Tuner 1:  Mostly (but not always, didn't fail in this lot) tunes 
quite nicely.

The output can be found in a PasteBin post at:

3) Next is a test with +166667Hz offset to the frequency:

The output may be found at:

  - When tunign with -a0, it demonstrates the same behavior as above.
  - When tuning with -a1, it fails with SNR of 0000.  Interestingly, 
tzap spat out this error:
ICE default IO error handler doing an exit(), pid = 19408, errno = 0

3) test with -166667Hz offset to the frequency:
  -a0  exhibits the same thing.  Haven't tested with -a1

The tzap output:


Is there something different between the PCI and the USB parts?  One 
seems to tune to SBS (well mostly) and the other doesn't.  I'm lost....

Have a good night!

More information about the linux-dvb mailing list