[linux-dvb] Re: Crash upon loading Nova-T 500 drivers

Michael Ditum mike at mikeditum.co.uk
Tue Dec 12 18:22:41 CET 2006

On 12/11/06, Robin Hill <dvb at robinhill.me.uk> wrote:
> On Mon Dec 11, 2006 at 06:12:12PM +0000, Michael Ditum wrote:
> > Hi,
> >
> > I've got a couple of Nova-T 500's I want to get working. I've got the
> latest
> > v4l-dvb tree from mercurial and compiled that. However whenever I load
> the
> > dvb-usb-dib0700 module (that is the correct one isn't it?) the machine
> locks
> > up. I can't contact the machine at all.
> >
> > When I reboot, the machine gets an NMI as soon as udev loads unless I
> remove
> > the card. I'm running FC5 and have tried kernel-smp-2.6.17-1.2174_FC5and
> > kernel-smp-2.6.18-1.2239.fc5 and pretty much the same thing happens. The
> > only difference is that under the 2.6.17 kernel it prints out a couple
> of
> > diagnostics messages before crashing. The last message is that it is
> loading
> > the firmeware. I got the firmware from
> >
> http://vaasa.wi-bw.tfh-wildau.de/~pboettch/home/files/dvb-usb-dib0700-01.fwthis
> > is the correct one to be loading isn't it?
> >
> > Unfortunately I've got to finish in a bit, I'll be back looking at the
> > problem again tomorrow though. I was just wondering if anyone had come
> > across this problem and whether they knew any way to fix it. If not if
> > anyone knows of any specific things I can try to help work out what the
> > problem is that would be great.
> >
> All I can suggest is checking that the firmware downloaded correctly -
> the md5sum on mine is 551df6387db5bf5a8ca4d10cc30beaa5.
> The md5sum of the firmware matches yours. I've jotted down the messages
I'm seeing below...

When I install the module:

dib0700: loaded with support for 2 different device-types
dvb-usb: found a 'Hauppauge Nova-T 500 Dual DVB-T' in cold state, will try
to load a firmware
dvb-usb: downlaoding firmware from file 'dvb-usb-dib0700-01.fw'
dib0800: firmware started successfully

there was then a long pause (about how long it took me to write all that
down) and then a load of messages scrolled past to do with page faults that
I couldn't write down in time before some more stuff scrolled past.... It
finished with a "Kernel panic - not syncing: Fatal execption in interrupt",
though every couple of minutes some other errors scroll past.

When I reboot with the card inserted and the module still installed i got:

Starting udev: BUG: unable to handle kernel paging request at virtual
address ea0a0a0
 printing eip:
*pde = 1fb53067

I have 3 Nova-500 cards and they are all doing the same thing. I've tried it
in a HP ML350PG4 server and an IBM x226 server.

Does anyone have any ideas?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20061212/0776de92/attachment-0001.htm

More information about the linux-dvb mailing list