[linux-dvb] Re: Difficulty getting b2c2_flexcop driver to recognize Air2PC rev 02

Mark Haun haunma at keteu.org
Fri Feb 10 21:06:55 CET 2006

Michael Krufky [mkrufky at linuxtv.org] wrote:
> Mark Haun wrote:
> >I recently acquired one of these cards on Ebay.  After compiling the dvb
> >modules for my kernel (2.6.15) and depositing the firmware file
> >dvb-fe-bcm3510-01.fw into /usr/lib/hotplug/firmware (I am on Debian), I
> >cannot get the driver to recognize the card.  Unfortunately, I cannot get
> >the driver to complain, either, so I am in need of debugging advice.
> >[...]
> Try:
> modprobe b2c2_flexcop_pci
> Yes, you already have b2c2_flexcop loaded, but b2c2_flexcop_pci is what 
> loads the card-specific stuff.  *MY* debian box does this automatically, 
> though.

That was my problem!  One of them anyway.  Usually I'm quite careful about
these things but I was in such a hurry to try out the card that I forgot to
select the kernel option for the PCI version.

Now I'm getting the expected dmesg output (including a bunch of i2c
complaints which I take it are caused by the extraneous front-end modules
failing to detect hardware?).  It finds the bcm3510 but I don't think it's
loading the firmware.  The stat command still doesn't show that file as
having been opened, and there are no kernel messages like "loading

azap is showing FE_LOCK on all of my local channels.  My signal numbers are
lower than the recommended 8000 (highest is KCTS with ~ 6c00), but the BER
is zero, so I should be seeing something, right?  If I run azap with the
"-r" option and then cat /dev/dvb/frontend0/dvr0 > test.ts  there is no
stream data (it sits there at zero size).

I recall someone else saying it was the firmware that made the difference on
this card.  Any idea why it might not be loading?  Something to fix in my
hotplug subsystem?



More information about the linux-dvb mailing list