[linux-dvb] KNC1-DVB-C - no frontend driver found

Sven Lankes sl at killefiz.de
Mon Jan 16 21:39:59 CET 2006


I'm trying to get a KNC1-DVB-C card working on my AMD64/nforce
mainboard. According to some posts I found in the mailinglist-archive
the card should work - at least without the ci-module attached. It
doesn't for me.

I have tried using cvs as of Saturday and a plain 2.6.15 kernel - no

Udev gives me ca0, demux0, dvr0 and net0 in /dev/dvb/adapter0/ but no

I have tried to get a definitive info on whether I need a firmware for
this card but my current guess from lots of googling is that I don't
need one.

This is the lspci-output:
01:08.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)

And here is the part of dmesg that I think is interesting (the rest is
here: http://killefiz.de/tmp/knc1.dmesg - in case there is anything else
of interest).

saa7146: register extension 'budget_av'.
ACPI: PCI Interrupt 0000:01:08.0[A] -> Link [APC3] -> GSI 18 (level, low) -> IRQ 18
saa7146: found saa7146 @ mem ffffc20000060000 (revision 1, irq 18) (0x1894,0x0020).
DVB: registering new adapter (KNC1 DVB-C).
adapter failed MAC signature check
encoded MAC from EEPROM was ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff
budget-av: ci interface initialised.
KNC1-0: MAC addr = 00:09:d6:ff:f1:0d
DVB: TDA10021: tda10021_readreg: readreg error (ret == -121)
budget-av: A frontend driver was not found for device 1131/7146
subsystem 1894/0020

Any hint is most welcome.

Sven Lankes <sl at killefiz.de> - Jabber: killefiz at amessage.de

More information about the linux-dvb mailing list