[linux-dvb] KNC1-DVB-C - no frontend driver found

Oliver Endriss o.endriss at gmx.de
Sat Jan 21 06:38:22 CET 2006

Sven Lankes wrote:
> I'm still trying to get a KNC1-DVB-C card to work here - no luck.
> I tried the card under windows (in this very machine) today and
> there it works like a charm.
> I have tried current cvs and some older snapshots (because someone told
> me that the card works for him with an older kernel) - but no matter
> what I do I always end up with:
> > DVB: TDA10021: tda10021_readreg: readreg error (ret == -121)
> > budget-av: A frontend driver was not found for device 1131/7146
> > subsystem 1894/0020
> in my dmesg (full dmesg: http://killefiz.de/knc1.dmesg).
> I'm still lost. The card works under windows and there are a couple of
> posts in the archive where people have (had) the card working. I have no
> idea where to go from here. 
> I'm still working on the assumption that I don't need a firmware for the
> card - google doesn't find anything wrt. the used chips and firmware and
> if I read the source correctly the TDA10021 doesn't need a firmware.
> Also hotplug doesn't look for a firmware. 
> If you have the slightest idea what I could try to get further here
> please let me know (killefiz at freenode in #linuxtv if you prefer that).

In the past there were some problems with KNC1 DVB-S cards. You might
check whether one of the following modifications helps for DVB-C:

(1) enable master reset in saa7146_core.c (line 354)

If it still does not work:

(2) slow down I2C speed: replace SAA7146_I2C_BUS_BIT_RATE_120 by
    SAA7146_I2C_BUS_BIT_RATE_480 in budget-core.c

Please report back if one of these changes fixes your problem.


VDR Remote Plugin available at

More information about the linux-dvb mailing list