[linux-dvb] DiBcom 3000P clone device

Florin Mihut mihut at t-online.de
Tue Jun 6 22:43:34 CEST 2006

                I have a USB DVB device. Unfortunately I got this as
        bulk and I have no idea about the producer/vendor.
                lsusb will provide the IDs 1584:60ff and 1584:6000
                Since I saw in Windows (from the inf files) that the
        device might be based on DiBcom MOD3000P1, I tried to add the
        ID's in the header files and to declare it as making part from
        the same group like DiBcom USB2.0 devices (inserted IDs in
        dvb-usb-ids.h and declared in dibusb-mc.c as "DiBcom USB2.0
        DVB-T clone MOD3000 (SATE)").
        Everything looks fine, I compile it and install it.
                When I insert the device I can see this:
        [4295772.389000] usb 3-2: new high speed USB device using ehci_hcd and address 5
        [4295772.609000] dvb-usb: found a 'DiBcom USB2.0 DVB-T clone MOD3000 (SATE)' in cold state, will try to load a firmware
        [4295772.674000] dvb-usb: downloading firmware from file 'dvb-usb-dibusb-'
        [4295772.726000] usbcore: registered new driver dvb_usb_dibusb_mc
        [4295772.973000] usb 3-2: USB disconnect, address 5
        [4295772.973000] dvb-usb: generic DVB-USB module successfully deinitialized and disconnected.
        [4295774.639000] usb 3-2: new high speed USB device using ehci_hcd and address 6
        [4295774.724000] dvb-usb: found a 'DiBcom USB2.0 DVB-T clone MOD3000 (SATE)' in warm state.
        [4295774.724000] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
        [4295774.729000] DVB: registering new adapter (DiBcom USB2.0 DVB-T clone MOD3000 (SATE)).
        [4295774.735000] dib3000: Found a DiBcom 3000P.
        [4295774.736000] DVB: registering frontend 1 (DiBcom 3000P/M-C DVB-T)...
        [4295774.738000] dvb-usb: schedule remote query interval to 150 msecs.
        [4295774.738000] dvb-usb: DiBcom USB2.0 DVB-T clone MOD3000 (SATE) successfully initialized and connected.
        ls will provide this (I already have a dvb-s device as adapter 0):
        crw-rw----  1 root video 212, 69 2006-06-01 00:47 /dev/dvb/adapter1/dvr0
        When the device is inserted in USB the LED will be lighted
        shortly (1 max 2 seconds) then it will turn off. I tried to scan
        with scan and w_scan but both did not find something. The device
        is not damaged nor the antenna since are working correctly in
        I know that might sound crazy but what is wrong there? How can I
        really see if the driver and firmware are correctly loaded? If
        the driver says "Fond a DiBcom 3000P" what it means, did it
        check for 3000P and the device responded that it has such chip? 
        Best regards,
        Florin Mihut

More information about the linux-dvb mailing list