[linux-dvb] USB troubles with DViCO FusionHDTV DVB-T Dual Digital

Dyks, Axel (XL) xl at xlsigned.net
Thu Jun 29 21:52:12 CEST 2006


Shanon Mulley wrote:
> ok. I have tried a different approach now.
> I have uninstalled lirc (I am using FC4, and was just using lirc as it
> came, and using yum/smart to maintain it).
> I have installed lirc from source (I think thats how you say it),
> ensuring when I run the ./setup thing, that I selected the option
> driver:devinput.
> I have modified my /etc/sysconfig/lircd file as outlined on
> http://www.mythtv.org/wiki/index.php/DVICO-Ultraview_Install_in_Australia#LIRC
> I start the lircd thingo with the command:
> "lircd -H dev/input -d /dev/input/event6"
Hmmm ... actually you don't need to have "lircd" running ...
> I then start irrecord with the command
> "irrecord -H dev/input -d /dev/input/event6"
... while you are recording a new "lircd.conf"

BTW: As far as I know, "irrecord" requires (the name of) a config file to
be passed as an argument which either refers to a copy of an existing or
generic "lircd.conf" file that fits your RC best or to a non-existing
file that will be created "from scratch".

> Upon which I am told that I dont have permission to acces
> /dev/input/event6. Which, upon checking, I dont.
> I switch to the root user, and the message is much more promising, and
> it tells me to hold down an arbitary button. I do so, and eventually
> get:
> irrecord: gap not found, can't continue
> irrecord: closing '/dev/input/event6'
... but since you have been asked to press and hold down a button on your RC
you obviously did supply the config file name. :-)

> Now I'm stumped. I dont know what else to try. Can anyone tell me what
> I've  done wrong?
You could try to add some "deb_info(...)" lines to "cxusb_rc_query()" in
"linux/drivers/media/dvb/dvb-usb/cxusb.c". Then recompile and load the "dvb-usb" module
using module parameter "debug=1".


More information about the linux-dvb mailing list