[linux-dvb] USB troubles with DViCO FusionHDTV DVB-T Dual Digital

simon wood simonwood74lst at gmail.com
Fri Jun 30 01:12:45 CEST 2006


On 6/29/06, Shanon Mulley <shanonmulleyster at gmail.com> wrote:
> ok. I have tried a different approach now.
> I have uninstalled lirc (I am using FC4, and was just using lirc as it
> came, and using yum/smart to maintain it).
> I have installed lirc from source (I think thats how you say it),
> ensuring when I run the ./setup thing, that I selected the option
> driver:devinput.
> I have modified my /etc/sysconfig/lircd file as outlined on
> http://www.mythtv.org/wiki/index.php/DVICO-Ultraview_Install_in_Australia#LIRC
> I start the lircd thingo with the command:
> "lircd -H dev/input -d /dev/input/event6"
> I then start irrecord with the command
> "irrecord -H dev/input -d /dev/input/event6"
> Upon which I am told that I dont have permission to acces
> /dev/input/event6. Which, upon checking, I dont.
> I switch to the root user, and the message is much more promising, and
> it tells me to hold down an arbitary button. I do so, and eventually
> get:
> irrecord: gap not found, can't continue
> irrecord: closing '/dev/input/event6'
> Now I'm stumped. I dont know what else to try. Can anyone tell me what
> I've  done wrong?

I had this problem with the same remote, but I cant remember exactly
what I changed that got rid of the message. I think that I got the
"gap not found" message when I was trying to use hiddev and then when
I compiled lirc and changed to use dev/input it started working ok (I
followed these steps from Axel pretty much):

Are you 100% sure that your remote is still event6? My usb device
event numbers did seem to change around a bit, so I added the UDEV
change similar to Axel's suggestion, which also fixed the permission
stuff as well.


More information about the linux-dvb mailing list