[linux-dvb] Error "Unknown symbol in module" with today's Mercurial

Timo Laitinen timolai at utu.fi
Sat Mar 11 20:31:17 CET 2006

On Thu, 09 Mar 2006 16:20:55 +0100 (MET)
"Jörg Knitter" <joerg.knitter at gmx.de> wrote:

> Hi,
> I wanted to test the latest Mercurial drivers with Kanotix 2005-04
> which is
> based on Debian Sid and has been updated to kernel 2.6.15. But using
> "./insmod.sh load" gives me the error message: "error inserting
> './cx88-dvb.ko': -1 unknown symbol in module".

I tried it today, and noticed that a certain module must be loaded
before the cx88-dvb.ko . Unfortunately, I don't have access to the
computer I tried it with at the moment, so I can't say which one... But
you can find it the same way: check from dmesg which symbol it doesn't
recognize, rgrep the symbol from the v4l directory, and check which
".ko" it reports. Then add it to the insmod.sh script before the

I have no idea why it is needed and why it's not there, maybe someone
who knows/can, can add it to the script...

Another module that isn't loaded automatically/with the
script (at least with my configuration), is i2c_algo_bit, needed by the
bttv et al. Could that also be put into the insmod.sh?

Best Regards,


More information about the linux-dvb mailing list