[linux-dvb] Error "Unknown symbol in module" with today's Mercurial

Joerg Knitter joerg.knitter at gmx.de
Thu Mar 16 13:02:32 CET 2006

Timo Laitinen wrote:
> On Thu, 09 Mar 2006 16:20:55 +0100 (MET)
> "Jörg Knitter" <joerg.knitter at gmx.de> wrote:
>> I wanted to test the latest Mercurial drivers with Kanotix 2005-04
>> which is
>> based on Debian Sid and has been updated to kernel 2.6.15. But using
>> "./insmod.sh load" gives me the error message: "error inserting
>> './cx88-dvb.ko': -1 unknown symbol in module".
> I tried it today, and noticed that a certain module must be loaded
> before the cx88-dvb.ko . Unfortunately, I don't have access to the
> computer I tried it with at the moment, so I can't say which one... But
> you can find it the same way: check from dmesg which symbol it doesn't
> recognize, rgrep the symbol from the v4l directory, and check which
> ".ko" it reports. Then add it to the insmod.sh script before the
> cx88-dvb.ko.

Thanks a lot, going to check this within the next days.

With kind regards


More information about the linux-dvb mailing list