[linux-dvb] AverMedia AverTV Hybrid+FM PCI (saa7134)

Hartmut Hackmann hartmut.hackmann at t-online.de
Sat May 13 00:33:28 CEST 2006


Hi,

gpatricio at gmail.com wrote:
> I read this message in the list, but I have not seen answers. I have 
> same the problem.
> Any idea? Thanks
> ---------------------------------------------------------------------------
> 
> Hello everybody,
> 
> I would like to report a new card that I borrowed recently to try on 
> Fedora Core 4 (2.6.15-1.1831_FC4).
> 
> AverMedia AverTV Hybrid+FM PCI (PAL version)
> --------------------------------------------
> 
> features: fullts??, AVin, ir
> 
> interface: PCI
> bridge: Philips SAA 1735 HL / 203
> tuner: Philips TD1316A
> 
> 
> frontend driver: mt352
> 
> pictures:
> http://myweb.tiscali.co.uk/stephanb/avertv_hybrid_fm01.jpg
>  <http://myweb.tiscali.co.uk/stephanb/avertv_hybrid_fm01.jpg>
> 
> http://myweb.tiscali.co.uk/stephanb/avertv_hybrid_fm02.jpg
>  <http://myweb.tiscali.co.uk/stephanb/avertv_hybrid_fm02.jpg>
> http://myweb.tiscali.co.uk/stephanb/averTV_HFM_tuner.png
> 
> 
> $ lspci -v
> 
> 00:0b.0 Multimedia controller: Philips Semiconductors SAA713X 
> Audio+video broadcast decoder (rev d1)
> 
>        Subsystem: Avermedia Technologies Inc: Unknown device 2c00
>        Flags: bus master, medium devsel, latency 32, IRQ 10
>        Memory at df000000 (32-bit, non-prefetchable) [size=2K]
> 
> 
>        Capabilities: [40] Power Management version 2
> 
> $ lspci -vn
> 00:0b.0 Class 0480: 1131:7133 (rev d1)
>        Subsystem: 1461:2c00
> 
> 
> AverTV offer a "linux driver" on their website. It contains RPMs with 
> the /etc/udev/devices/dvb/... device nodes and the following modules:
> 
> /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/media/video/mt352.ko
> /lib/modules/2.6.11-1.1369_FC4/kernel/drivers/media/video/saa7134/saa713x.ko
> 
> There is an install script that installs the rpm and insmod the modules 
> AverMedia consider to be relevant. No doubt this approach is going to 
> fail on any linux box not running the expected distro and kernel version.
> 
> 
> http://www.avermedia.com/cgi-bin/support_driverbympdpro.asp?category=TV%20Card&category2=Hybrid&proname=AVerTV%20Hybrid%20FM%20PCI
>  <http://www.avermedia.com/cgi-bin/support_driverbympdpro.asp?category=TV%20Card&category2=Hybrid&proname=AVerTV%20Hybrid%20FM%20PCI>
> 
> in the AVerMedia install script one can read:
> auto_insmod()
> {
> 
>        rmmod saa7134     1> /dev/null 2> /dev/null
>        modprobe dvb-core 1> /dev/null 2> /dev/null
>        modprobe i2c-core 1> /dev/null 2> /dev/null
> 
>        modprobe videodev 1> /dev/null 2> /dev/null
> 
> modprobe mk352 1> /dev/null 2> /dev/null # note the spelling mistake !!
> 
>        modprobe saa713x  1> /dev/null 2> /dev/null
> 
>        dialog --title "Install" --backtitle "AVerMedia Device Driver" \
> 
> --msgbox "The driver is installed.\nYou might reboot your system to 
> enjoy it!!" 12 60
> 
> }
> 
> I tried the following:
> rmmod saa7134
> modprobe saa7134-dvb
> modprobe mt352
> 

When you use the driver from linuxtv.org and force the card type to 85
modprobe saa7134 card=85
modprobe saa7134-dvb
the dvb section might work (same channel decoder, same tuner )

Good luck
    Hartmut



More information about the linux-dvb mailing list