[linux-dvb] buffer underruns with budget-av/-ci (vpeirq)

Matthias Dahl mldvb at mortal-soul.de
Sun Nov 12 16:40:17 CET 2006

Hi Oliver.

> You could also bypass tasklet processing completely, i.e.
> replace
> 	tasklet_schedule(&budget->vpe_tasklet);
> by
> 	vpeirq(budget);
> But that's bad programming style. ;-)

Sorry for my late reply. So far I tried the following:

 - replaced "tasklet_schedule" by "tasklet_hi_schedule"
 - even bypassed tasklet processing
 - updated to http://linuxtv.org/hg/~endriss/v4l-dvb (yesterday)
   and kernel 2.6.19-rc5-git2

No matter what I do: I keep getting those darn

  saa7146 (0) vpeirq: used 1 times >80% of buffer (65612 bytes now)

msgs every time I do a X -> console -> X switch. As I stated earlier, this is 
only with the nvidia binary only driver (please, don't hurt me -g-). Things 
work fine with Xorg's own 'nv' driver. (let's define 'fine': no dvb problems 
but also a pretty slow desktop)

Now the problem is: I wrote about this to nvidia but so far nothing except for 
a few short msgs. What is unclear at this point: is this a problem with the 
dvb subsystem which is triggered by the nvidia driver somehow or is the 
nvidia driver doing something very wrong. :-(

Nevertheless- I'd really like to get this fixed somehow. If there is anything 
I can do to debug this, please let me know... I am not so much familiar with 
the kernel and dvb sources to get to the bottom of this myself.

Thanks a lot in advance,

PS: Things worked fine with 2.6.18.x and a max bufsize.

More information about the linux-dvb mailing list