[linux-dvb] performance degradation? (dvb_usb_dtt200u)

José Oliver Segura primijos at gmail.com
Mon Nov 13 03:06:31 CET 2006

       Hi all,

       after seeing that Zaapa is not supported and having some
troubles with an AverMedia Volar (which wasn't able to find any
channel using the roof antenna, only with the portable antenna -
[curious, the Zaapa one worked just the reverse way]), I've been able
to get a Freecom dvb usb stick.

       Things went ok (nice!) at first: downloaded the firmware,
compiled & installed code from Mercurial, plug the stick and it's

       After that, used scandvb to create channels.conf, OK.

       I've been able to watch TV using MPlayer with that
channels.conf file, great.

       It works OK, but after sometime (maybe one hour, but is not
deterministic), everything goes bad: image starts to goes
slowmotion/frozen/pixelated, sound gets crappy, with lot of whistles
(of course, audio and video are not synchronized at that point), and I
have to close mplayer and start again.

       At this point, the degradation occurs before, just one or two
minutes after the second mplayer starts running. At that point, It
cannot be solved just restarting mplayer (neither removing/reinserting
the dvb stick).

       What I've tried is to remove the stick, rmmod dvb_usb_dtt200u
and start again, and it seems to work (I mean, it seems I can get an
hour of tv..), but after some time all the problems start again. I've
noticed, before the first rmmod, that dvb_usb_dtt200u was reported to
be used by 4294967293 times (see lsmod output below) :-/ Usually, that
number is 4/5 in my case (at the time of writing this, I've not been
able to reproduce it, now -regarding that it's not working-, keeps the
usage count at 4)

        Trying to remove "mplayer" from the equation, I've tried to do
a test just with stream recording using tzap/cat and generating an
mpeg file, and it seems to be the same. Playing it with mplayer shows
up that the problem is in the mpeg data, not in mplayer.

       Is it possible that the driver/frontend has some bug that
causes that time/use malfunction?

        I'll be glad to help if I can. Below comes some information:

- OS Fedora Core 6 (kernel 2.6.18 i686 reinstalled after fedora bug
installing the 386 kernel)


Bus 006 Device 006: ID 14aa:0226 AVerMedia (again) or C&E
Bus 006 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 003: ID 05e3:0606 Genesys Logic, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 004 Device 004: ID 067b:3507 Prolific Technology, Inc. PL3507 ATAPI6 Bridge
Bus 005 Device 001: ID 0000:0000

lsmod | grep dvb:

dvb_usb_dtt200u        16900  4294967293
dvb_usb                28044  1 dvb_usb_dtt200u
dvb_core               83496  1 dvb_usb
dvb_pll                18692  1 dvb_usb
i2c_core               25537  4 i2c_ec,i2c_i801,dvb_usb,dvb_pll

dmesg (filtered):

usb 6-2: new high speed USB device using ehci_hcd and address 5
usb 6-2: configuration #1 chosen from 1 choice
dvb-usb: found a 'WideView WT-220U PenType Receiver (Typhoon/Freecom)'
in cold state, will try to load a firmware
dvb-usb: downloading firmware from file 'dvb-usb-wt220u-fc03.fw'
usbcore: registered new driver dvb_usb_dtt200u
usb 6-2: USB disconnect, address 5
dvb-usb: generic DVB-USB module successfully deinitialized and disconnected.
usb 6-2: new high speed USB device using ehci_hcd and address 6
usb 6-2: configuration #1 chosen from 1 choice
dvb-usb: found a 'WideView WT-220U PenType Receiver (Typhoon/Freecom)'
in warm state.
dvb-usb: will use the device's hardware PID filter (table count: 15).
DVB: registering new adapter (WideView WT-220U PenType Receiver
DVB: registering frontend 0 (WideView USB DVB-T)...
input: IR-receiver inside an USB DVB receiver as /class/input/input5
dvb-usb: schedule remote query interval to 300 msecs.
dvb-usb: WideView WT-220U PenType Receiver (Typhoon/Freecom)
successfully initialized and connected.
dvb-usb: recv bulk message failed: -110
drivers/usb/input/hid-core.c: timeout initializing reports
input: Digital TV Receiver Digital TV Receiver as /class/input/input6
input: USB HID v1.10 Keyboard [Digital TV Receiver Digital TV
Receiver] on usb-0000:03:00.2-2

Error message from Mplayer (either direct playing dvb:// or reading a
recorded file):

Too many video packets in the buffer: (433 in 8428292 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

       I don't have idea of what other data can I send to help, but if
it's needed, just let me know.


More information about the linux-dvb mailing list