[linux-dvb] Hauppauge WinTV NOVA-T Stick problems

Steven Cockeram steven.cockeram at gmail.com
Tue Nov 14 13:58:39 CET 2006

I've build the drivers from http://linuxtv.org/hg/~pb/v4l-dvb, but the 
frontend on the stick is still not recognized - (on FC6) I get:

usb 2-8: new high speed USB device using ehci_hcd and address 20
usb 2-8: configuration #1 chosen from 1 choice
dib0700: loaded with support for 2 different device-types
FW GET_VERSION length: -32
cold: 1
dvb-usb: found a 'Hauppauge Nova-T Stick' in cold state, will try to 
load a firmware
dvb-usb: downloading firmware from file 'dvb-usb-dib0700-01.fw'
dib0700: firmware started successfully.
dvb-usb: found a 'Hauppauge Nova-T Stick' in warm state.
dvb-usb: will pass the complete MPEG2 transport stream to the software 
DVB: registering new adapter (Hauppauge Nova-T Stick).
I2C read failed on address 9
I2C read failed on address 40
DiB7000P:-D-  DiB7000PC not detected
I2C read failed on address 9
DiB7000M:i2c read error on 896
DiB7000M:-E-  DiB7000M: wrong Vendor ID (read=0x400d)
dvb-usb: no frontend was attached by 'Hauppauge Nova-T Stick'
dvb-usb: Hauppauge Nova-T Stick successfully initialized and connected.
usbcore: registered new driver dvb_usb_dib0700

Interesting things here are:

FW GET_VERSION length is returning -32?

I2C reads of 9, 40 and 896 are all failing why ?

This is with a *new* WinTV NOVA-T USB stick.

I've tried plugging it in and out several times (10+) but it makes no 

Any help would be greatfully received.


More information about the linux-dvb mailing list