[linux-dvb] Still no frontend on KNC1 DVB-C Card

Sven Lankes sl at killefiz.de
Sat Nov 18 20:42:16 CET 2006

On Sat, Nov 18, 2006 at 01:20:14AM +0000, Andrew de Quincey wrote:

> Just tried my card - it reports the following, and the TDA10021 is detected 
> ok:
> saa7146: found saa7146 @ mem d0994800 (revision 1, irq 185) (0x153b,0x1156).
> Its a rebadged KNC1 DVBC card - Terratec Cinergy. I dunno quite what to 
> suggest now... obviously SOMETHING is different (as it works in windows), but 
> AFAIK, it should be working with the original code. 
> Hmm, I see the tda10021 has a configurable i2c address; could you give the 
> attached patch a go?

I did.

The result is:

[17179846.012000] ACPI: PCI interrupt for device 0000:00:09.0 disabled
[17179850.988000] saa7146: register extension 'budget_av'.
[17179850.988000] ACPI: PCI Interrupt 0000:00:09.0[A] -> GSI 17 (level, low) -> IRQ 185
[17179850.988000] saa7146: found saa7146 @ mem e0ab6c00 (revision 1, irq 185) (0x1894,0x0020).
[17179850.988000] saa7146 (0): dma buffer size 192512
[17179850.988000] DVB: registering new adapter (KNC1 DVB-C).
[17179851.052000] adapter failed MAC signature check
[17179851.052000] encoded MAC from EEPROM was ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff
[17179851.584000] KNC1-0: MAC addr = 00:09:d6:ff:f1:0d
[17179851.744000] DVB: registering frontend 0 (Philips TDA10021 DVB-C)...
[17179851.744000] budget-av: ci interface initialised.

Thanks a lot.

I'm going to find out now if that means I can actually get a picture out
of the card now.


More information about the linux-dvb mailing list