[linux-dvb] CI Module w/ Terratec DVB-C

Sven Lankes sl at killefiz.de
Fri Nov 24 00:45:59 CET 2006

My quest for working DVB-C input under linux isn't over yet. 

I have now aquired the following:

 1) Terratec Cinergy 1200 - DVB-C Card
 2) KNC1 Cineview CI-Adapter
 3) Mascom / Cryptoworks CA-Module

I am not very successful yet. 

I'm using hg head dvb-drivers and apps (also tried 2.6.17 from ubuntu
edgy - no difference). FTA channels work fine.

The CA-Module is found by the driver:

[17179595.008000] budget-av: ci interface initialised.
[17179595.108000] budget-av: cam inserted A
[17179596.460000] dvb_ca adapter 0: DVB CAM detected and initialised successfully

I can scan for channels. If I then try to tune into the channel it works too:

root at myth:/usr/src/dvb-apps/util/scan# zap "ARENA HOME (tividi)(tividi)"
Using frontend "Philips TDA10021 DVB-C", type DVB-C
CAM supports the following ca system ids:er 00195000 | unc ffffffff |
status SCVYL | signal 8d8d | snr efef | ber 00195000 | unc ffffffff | FE_HAS_LOCK
Received new PMT - sending to CAM...
CAM Application type: 01
CAM Application manufacturer: 4a20
CAM Manufacturer code: 4a20
CAM Menu string: Cryptoworks

Next I'm trying (in another terminal - leaving zap running) to save some of the data:

root at myth:/usr/src/w_scan/w_scan-20060903# dvbstream 573 574 -o > out.mpg
dvbstream v0.6 - (C) Dave Chapman 2001-2004
Released under the GPL.
Latest version available from http://www.linuxstb.org/
dvbstream will stop after -1 seconds (71582788 minutes)
Output to stdout
Streaming 2 streams

But the resulting data doesn't play back (using mplayer). If I do the
same procedure on a FTA channel everything works.

I have also tried mythtv and kaffeine - both allow me to watch FTA but
fail on pay-channels.

Any ideas?


More information about the linux-dvb mailing list