[linux-dvb] ASUSTEK P7131 Dual TV dvb mode?

hermann pitton hermann-pitton at arcor.de
Sat Oct 14 01:27:31 CEST 2006


Am Freitag, den 13.10.2006, 01:58 +0200 schrieb Hartmut Hackmann:
> Hi, folks
> In my pesonal repository:
>    http://linuxtv.org/hg/~hhackmann/v4l-dvb
> are some updates for these cards:
> - Hermanns bugfix for the i2c gate control
> - support for the :4876 variant without eeprom
> - Hermanns? proposal for improved antenna switching.
> Please test it and report.
> Owners of the 'old' variant still should not need a firmware
> file. The patch relies on an undocumented feature of the tda10046:
> If it finds an eeprom, it will boot from it anyway and the
> driver does not try to download if there is a valid firmware in the
> chip.
> The antenna switching now uses the radio/dvb input even if composite
> or s-video is selected to allow parallel dvb and capture of these
> inputs.

at least a short report for now.

On the old card (1043:4862) no problems with the firmware from eeprom.
(also means a flashtool would be fine to upgrade)

Yes, I proposed to try to hold the fm/dvb abtenna input when using
composite and svideo, since it was possible to experiment with parallel
captures previously, before the antenna switch in saa7134-dvb.c was
introduced, by using the analog input for dvb-t.

Parallel works, but not well investigated here, which apps play nice
with it.

When dvb apps (xine, kaffeine, mplayer) are already running,
starting/stopping for example tvtime or mencoder causes glitches in the
dvb stream from which the dvb apps may or may not recover.
On tvtime start there is a television gpio switch visible (--input=1 was
forced), but it happens also on closing.
Rule of thumb would be currently to start the analog stuff at first.

There is one major issue, Hartmut you know about, but I ran in it for a
moment until I remembered and produced a invalid file on the disk.

Don't use planar formats!
Packed outfmt=bgr32 on input=1 worked then at once with dvb-t.

Regarding the other thread about the :4876 card amode=0 might do, but
with the current testing repo I don't get A2 MONO reported anymore, also
not with xawtv-3.95, always scan in progress. A little late for it now.


More information about the linux-dvb mailing list