[linux-dvb] Re: Kernel oops with new DiB7000M driver (was: DiB7000M-driver released (Nova-T Stick, AverMedia and others))

Patrick Boettcher patrick.boettcher at desy.de
Wed Oct 25 12:18:30 CEST 2006


On Tue, 24 Oct 2006, Nicolas George wrote:
> Le sextidi 26 vendémiaire, an CCXV, Patrick Boettcher a écrit :
> > in my repository (http://linuxtv.org/hg/~pb/v4l-dvb) I just committed a
> > first working version of the dib7000m/p-driver along with some
> > modifications in the dib0700-driver.
> Thanks for your efforts.
> > Please load the dib7000m-driver with debug=1 in case it does not work and 
> > reply to this Email but change the subject (like: "Problem (was: DiB7000M 
> > ...") - success reports (Yes I want them as well) can be replied without 
> > changing the subject.
> I just tried a snapshot with my new generation WinTV Nova-T USB2 stick, and
> got a kernel oops. But before that it worked.
> Here are the details: the host is Thurion64-based and runs a kernel
> from kernel.org. The first time I tried, scan made the kernel oops. The
> second time (after reboot, and adding debug=1), scan worked (twice, the
> first time with the small antenna in vain) and found channels, and mplayer
> could show some trash television.
> It oopsed when I tried to change the channel. I put the kernel messages at
> the end of my mail. I believe I still have the corresponding unstripped
> kernel binary if it is necessary to exploit them.
> Anyway, this is an encouraging start.
> Regards,
> -- 
>   Nicolas George
> [ 1469.124805] DiB7000M:-E-  No valid AGC configuration found for band 0x08

Strange. But not related.

> [ 1880.948479] APIC error on CPU0: 40(40)
> [ 1891.087908] hub 1-0:1.0: port 6 disabled by hub (EMI?), re-enabling...

Here the problem starts. The USB-Port is dying.

> [ 1891.087915] usb 1-6: USB disconnect, address 2

And the device disconnects. I assume while you are watching TV. That's why 
the following Oops. The dvb-core is not hotpluggable so it cannot handle 
suddenly disappearing devices.

> [ 1896.963791] Unable to handle kernel NULL pointer dereference at 0000000000000021 RIP: 

What is your USB controller?


More information about the linux-dvb mailing list