[linux-dvb] Yakumo QuickStick Basic DVB-T question

Alan Chandler alan at chandlerfamily.org.uk
Sun Sep 10 10:36:19 CEST 2006

On Sunday 10 September 2006 01:56, Tobias Stoeber wrote:
> Hi anyone,
> I have got a recent Yakumo Quicktick Basic DVB-T here. Linux distribution
> is Debian sarge, kernel is 2.6.17 from kernel.org with recent drivers from
> mercurial. DVB-T reception is in Germany in region 'Braunschweig'.
> Plugging it into USB first finds the 'WideView WT-220U PenType Receiver
> (Typhoon/Freecom)' in cold state, loads firmware 'dvb-usb-wt220u-fc03.fw'
> and then recognizes the pen in warm state. usb ids seem therefore to be the
> "new" ids (and unlike those stated in the DVB-T hardware list!)

This seems to be the same as the freecom sticks I purchased here in the uk.  
The vendor/product ids are 14aa:0225 (in cold state, warm state changes them 
to 14aa:0226).

> After that the usual /dev/dvb/adapter0 devices are present.
> Using 'scan' problems begin, as not all channels are found and tuning
> errors occur. Using a channel that is recognized gives me the following
> output, e.g.:

See the post just above, where I had to input more channels into the scan 
file.  I am new to this game, so I didn't know what to expect.  Does scan use 
the channel tuning information it is given as a starting point, because as I 
said, once it had tried all the channels I gave it, it went off trying some 

If that is the case, should the channel information in the scan file you give 
it be the lowest frequency?  In the Crystal Palace case it gives only the 
first of 6 muxes, and that happens not to be the lowest frequency.

> sh$ tzap ZDF
> using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
> tuning to 490000000 Hz
> video pid 0x0221, audio pid 0x0222
> status 1f | signal 4e4e | snr afaf | ber 00000000 | unc 00000000 |
> FE_HAS_LOCK status 1f | signal 4f4f | snr b7b7 | ber 00000000 | unc
> 00000000 | FE_HAS_LOCK status 1f | signal 4e4e | snr afaf | ber 00000000 |
> unc 00000000 | FE_HAS_LOCK
> So far reception is only possible in minimal small pieces, totally
> pixelized picture and broken audio.

I am only a few miles/kilometers from the Crystal Palace transmitter in the 
UK.  I can look out of my house and see it near the top of a hill across the 
valley with easy line of sight.  I have a loft aerial, which is split (just 
by wiring the split) into two coax cables, one of which comes down the back 
of the house and into a sony tv set.  Picture there is perfect.  The second 
side comes down the front of the house and is split (again via a simple y 
splitter) to go to an unused socket in our dinning room, and the other side 
into my study where all my computers are.

In the study, it is split three ways, one into a Panasonic PVR, the other two 
into two of these freecom sticks.

Nevertheless, despite all the splitting, I would have expected a strong signal 
(on the other side of our house, my wife has a digitial television in our 
kitchen driven from an internal aerial).

However, without any amplification, I get problems with pixellation and sound 
breakup on the Panasonic PVR, but placing a small aerial amplifier just 
before the two y splitters that give the three feeds in my study, these go 

Strangely the signal value reported by tzap when I do this changes from about  
4c4c when there is no amplifier to 3838 when there is.  IN fact, I can make 
the signal strength numbers rise, by adding coax segments (ie the little 
aerial extension leads with a plug/socket on each end) into the run from the 
aerial.  So despite the documentation saying that signal strength should be 
above 8000, it almost seems to me that it needs to be below 4000 to work.

(is this a dvb driver issue inverting a value somewhere?)

> No teletext/videotext possible using alevt.

Not tried this

> EPG works using klear in a recent version. Using klear 0.4 gives me for
> instance the following output:
> AudioPid: 386
> VideoPid: 385
> Not multiplexed? 0xbd
> Not multiplexed? 0xbd
> Not multiplexed? 0xbd
> Not multiplexed? 0xbd
> Not multiplexed? 0xc0
> Not multiplexed? 0xc0
> Not multiplexed? 0xbd
> Not multiplexed? 0xc0

Not tried this - and I don't understand what you are saying (but maybe I would 
if I did try it).

> Reception is via logper antenna in-house, good signal with STB from
> Skymaster (DT400) and using the Yakumo stick under Windows XP (including
> recoding to disk).
> So I would just rule out a too weak signal. But whats the difference
> between using the Yakumo stick under windows and using it under linux?
> Any suggestions or anyone with a similar problem?

I have another problem, and that is, as soon as I plug my second stick in it 
appears to interfere with the first one.  This seems to be the usb layer 
reporting protocol errors, I was about to try and sprinkle some printk code 
in the modules to understand what was happening a bit better, as I wondered 
if the firmware in the sticks are responding to messages that are not meant 
for it or something like that.

Alan Chandler

More information about the linux-dvb mailing list