[linux-dvb] Re: Freecom USB DVB-T stick (id 14aa:022b) still doesn't work.

Oscar Rodriguez Fonseca oscar at vranis.com
Thu Sep 21 09:53:07 CEST 2006

El mié, 20-09-2006 a las 22:25 +0100, Robin Bowes escribió:

> > usb 5-7: new high speed USB device using ehci_hcd and address 14
> > usb 5-7: configuration #1 chosen from 1 choice
> > dvb-usb: found a 'WideView WT-220U PenType Receiver (based on ZL353)' in
> > cold state, will try to load a firmware
> > dvb-usb: recv bulk message failed: -110
> > 
> > 
> > The thing is, this used to work. It's got broken in the course of an
> > upgrade over the last month or two. Perhaps I should regress to an
> > earlier kernel version?
> This is using FC5.

My freecom stick is older (id 14aa:0221) and it also has stopped to work
on my intel based laptop (debian etch + some sid packages. Linux kernel:

The fact is that I remember having seen that "dvb-usb: recv bulk message
failed: -110" error and watching fine TV with the stick.

Yesterday night I tried an older kernel version ( and did not
work so I am clueless.

Also tested with latest CVS (well, mercurial ;) ) repository. And the
same happens.

When using tzap to tune in:
$ tzap -r TM3
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
tuning to 810000000 Hz
video pid 0x006f, audio pid 0x0071
status 1f | signal 2e2e | snr e7e7 | ber 00000000 | unc 00000000 | FE_HAS_LOCK
status 1f | signal 2929 | snr e5e5 | ber 00000000 | unc 00000000 | FE_HAS_LOCK

The led on the device is always blinking green (when it was working, the light didn't blink)

Then (in another xterm):
$ cat /dev/dvb/adapter0/dvr0 | mplayer -
MPlayer 1.0pre8-4.1.2 (C) 2000-2006 MPlayer Team
CPU:         Intel(R) Pentium(R) M processor 1.86GHz (Family: 6, Model: 13, Step
ping: 8)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup 

Playing -.
Reading from stdin..
Cache fill:  0.00% (0 bytes) .

And some seconds later...
Cache fill:  3.12% (8192 bytes)   

That's all. No image, no errors in the syslog.

Surprisingly enough, it works fine on my desktop (AMD-AthlonXP based. Linux Debian sarge).

I am clueless. Also tried downgrading dvb-utils, and latest, built from source.

¿Any idea? Thanks in advance.


More information about the linux-dvb mailing list