[linux-dvb] DViCO FusionHDTV DVB-T Dual Digital problems

Damien Dusha damiendusha at netspace.net.au
Tue Sep 26 14:04:51 CEST 2006

Hi Mark,

Not much help, but some sympathy, and some "out there" ideas.

I am having similar problems in Brisbane with 9 and SBS in Brisbane, 
until one day they magically started working, though the PCI can be slow 
to lock.
Given that most people that reported problems are using FC5 (both the 
FC5 kernels and vanilla kernels) I used a separate HDD and installed 
Ubuntu.  It magically worked after installing a 2.6.17.?? (can't 
remember - I think it was the last before 2.6.18 was released) vaniall 
kernel, and apply Chris Pascoe's test branch drivers (see below).  
Strange, but even stranger was when I put back my old HDD with fedora, 
it magically worked as well!  The only possible explanation (however 
implausable) is that the case was somehow acting as an antenna for the 
signal/noise (i.e. the case was off), which was killing the signal. If 
anyone has a better suggestion, I'm all ears.  But now, the case is back 
on and it's still reasonable... though the PCI can be quite slow to lock 
at times.

A friend of mine, also with a dual digital, experiences the same problem 
under FC5, though he is debating whether it's a signal strength issue or 

I have very good signal strength in windows too.

There is a way around the 16667Hz offset problem - Chris Pascoe's 
repository has an experimental driver version to fix the divider error 
what causes the need for the 16667Hz offset.

Follow the mercurial instructions, except change the hg branch to the 
hg clone http://linuxtv.org/hg/~pascoe/v4l-dvb-test/

And this will at least fix the offset.

You will probably get an error compiling complaining about dependencies 
dst(ca) or something like that.  Just make install anyway and it will 
install the drivers.

Out of curiorsity, when trying to lock, do you get a lot of kernel 
messages saying something like:

cx88 timeout

or similar?  That's what I am getting when it is failing to tune.

Let us know if you have any luck, and if you do have a spare HDD kicking 
around somewhere, try Ubuntu or something else and see if that works - I 
have no idea why mine suddenly started working (not that I am 
complaining!).  I have no idea why the distro would have any bearing if 
you are using a vanilla kernel, but I am grasping at straws here myself...


Kielogl wrote:
> Just added a new DViCO FusionHDTV DVB-T Dual Digital tuner card for 
> MythTV on FC5 and have come across some problems. The card seems to be 
> initializing ok, as per dmesg | grep -i dvb:
> cx2388x dvb driver version 0.0.6 loaded
> CORE cx88[0]: subsystem: 18ac:db50, board: DViCO FusionHDTV DVB-T Dual 
> Digital [card=44,autodetected]
> cx88[0]/2: cx2388x based dvb card
> DVB: registering new adapter (cx88[0]).
> DVB: registering frontend 0 (Zarlink ZL10353 DVB-T)...
> dvb-usb: found a 'DViCO FusionHDTV DVB-T Dual USB' in cold state, will 
> try to load a firmware
> dvb-usb: downloading firmware from file 'dvb-usb-bluebird-01.fw'
> usbcore: registered new driver dvb_usb_cxusb
> dvb-usb: generic DVB-USB module successfully deinitialized and 
> disconnected.
> dvb-usb: found a 'DViCO FusionHDTV DVB-T Dual USB' in warm state.
> dvb-usb: will pass the complete MPEG2 transport stream to the software 
> demuxer.
> DVB: registering new adapter (DViCO FusionHDTV DVB-T Dual USB).
> DVB: registering frontend 1 (Zarlink ZL10353 DVB-T)...
> input: IR-receiver inside an USB DVB receiver as /class/input/input2
> dvb-usb: schedule remote query interval to 150 msecs.
> dvb-usb: DViCO FusionHDTV DVB-T Dual USB successfully initialized and 
> connected.
> I am using the current FC5 kernel, 2.6.17-1.2187_FC5, and last built 
> v4l-dvb from the mercurial source at linuxtv.org earlier this week (24 
> Sept 2006).
> Both receivers initially work fine in MythTV, except the PCI receiver 
> is not able to receive the SBS channel here in Melbourne, Australia. 
> SBS works fine on the USB receiver. (To get SBS and channel Nine to 
> work at all, I had to add the +166667Hz offset to the channel 
> frequency, as per 
> http://www.linuxtv.org/pipermail/linux-dvb/2006-July/011623.html.)
> It seemed like a signal strength problem with the SBS channel, as lock 
> can be slow and frame updates are delayed/pixelated/corrupt. However, 
> I tried the card/antenna in a WinXP machine and all channels are 
> received perfectly. The Windows receiver app shows the signal strength 
> is 100% for all channels:
> ABC   - 100% (29.1dB)
> Seven - 100% (30.1dB)
> Nine  - 100% (30.6dB)
> Ten   - 100% (29.0dB)
> SBS   - 100% (25.3dB)
> After working ok initially for anywhere up to a day or so (except for 
> SBS on PCI), the second problem happens. The USB receiver suddenly 
> stops working and syslog is flooded with "bulk message failed" messages:
> dvb-usb: recv bulk message failed: -71
> dvb-usb: bulk message failed: -32 (1/0)
> last message repeated 14 times
> dvb-usb: bulk message failed: -32 (1/0)
> last message repeated 19 times
> dvb-usb: bulk message failed: -32 (1/0)
> last message repeated 20 times
> ...
> If I just reboot, the /dev/dvb/adapter1/* devices are missing. The 
> only way I can get it working again is by shutting down the system, 
> and pulling the power before restarting, so the firmware for the USB 
> receiver is reloaded.
> Would much appreciate any advice on how to get some stability back 
> with the new card's USB receiver and on the SBS channel reception for 
> the PCI receiver.
> Thanks in advance,
> Mark.
> __________________________________________________
> Do You Yahoo!?
> Tired of spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
> ------------------------------------------------------------------------
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

More information about the linux-dvb mailing list