[linux-dvb] Re: WinTV HVR1300 drivers

Emilio Castellano ecastellano at microgenesis.es
Fri Sep 29 19:12:52 CEST 2006

Steven Toth wrote:
>> I grab the latest hg drivers from 
>> http://linuxtv.org/hg/~stoth/hvr1300-final  as Steven said in a 
>> message of 06 Sep 2006,
>> I followed the usual procedure:
>> make clean
>> make distclean
>> make
> This has now reached the mainline. Download 
> http://www.linuxtv.org/hg/v4l-dvb and try again. This problem has been 
> resolved.
First of all thank you for the quick answer,..

I grab the sources, and compile them..
 >> make clean
 >> make distclean
 >> make
 >> make install
this are the dmesg relevant messages..
cx2388x cx88-mpeg Driver Manager version 0.0.6 loaded
cx2388x alsa driver version 0.0.6 loaded
cx2388x v4l2 driver version 0.0.6 loaded
CORE cx88[0]: subsystem: 0070:9601, board: Hauppauge WinTV-HVR1300 
DVB-T/Hybrid MPEG Encoder [card=56,autodetected]
TV tuner 63 at 0x1fe, Radio tuner -1 at 0x1fe

Here the first caveat.. Radio tuner doesn't seem to be detected.

i2c-algo-bit.o: (0) scl=1, sda=1
i2c-algo-bit.o: (1) scl=1, sda=0
i2c-algo-bit.o: (2) scl=1, sda=1
i2c-algo-bit.o: (3) scl=0, sda=1
i2c-algo-bit.o: (4) scl=1, sda=1
i2c-algo-bit.o: cx88[0] passed test.
tveeprom 0-0050: Encountered bad packet header [00]. Corrupt or not a 
Hauppauge eeprom.
cx88[0]: warning: unknown hauppauge model #0
cx88[0]: hauppauge eeprom: model=0
input: cx88 IR (Hauppauge WinTV-HVR130 as /class/input/input3
cx88[0]/2: cx2388x 8802 Driver Manager
tuner 0-0042: chip found @ 0x84 (cx88[0])
tda9887 0-0042: tda988[5/6/7] found @ 0x42 (tuner)
tuner 0-0043: chip found @ 0x86 (cx88[0])
tda9887 0-0043: tda988[5/6/7] found @ 0x43 (tuner)
tuner 0-004a: chip found @ 0x94 (cx88[0])
tda9887 0-004a: tda988[5/6/7] found @ 0x4a (tuner)
tuner 0-004b: chip found @ 0x96 (cx88[0])
tda9887 0-004b: tda988[5/6/7] found @ 0x4b (tuner)
tuner 0-0060: All bytes are equal. It is not a TEA5767
tuner 0-0060: chip found @ 0xc0 (cx88[0])
tuner 0-0060: type set to 0 (Temic PAL (4002 FH5))
tuner 0-0061: chip found @ 0xc2 (cx88[0])
tuner 0-0062: chip found @ 0xc4 (cx88[0])
tuner 0-0063: chip found @ 0xc6 (cx88[0])
tuner 0-0064: chip found @ 0xc8 (cx88[0])
tuner 0-0065: chip found @ 0xca (cx88[0])
tuner 0-0066: chip found @ 0xcc (cx88[0])
tuner 0-0067: chip found @ 0xce (cx88[0])
tuner 0-0068: chip found @ 0xd0 (cx88[0])
tuner 0-0069: chip found @ 0xd2 (cx88[0])
tuner 0-006a: chip found @ 0xd4 (cx88[0])
tuner 0-006b: chip found @ 0xd6 (cx88[0])
tuner 0-006c: chip found @ 0xd8 (cx88[0])
tuner 0-006d: chip found @ 0xda (cx88[0])
tuner 0-006e: chip found @ 0xdc (cx88[0])
tuner 0-006f: chip found @ 0xde (cx88[0])
wm8775 0-001b: chip found @ 0x36 (cx88[0])
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
cx88[0]/1: CX88x/0: ALSA support for cx2388x boards

No radio, nor dvb at the moment registered..

saa7130/34: v4l2 driver version 0.2.14 loaded
¿¿¿¿¿¿¿¿¿¿¿¿¿????????????? I just have plugged the hauppage right now

I tried out kaffeine.. no dvb-t working.
I tried out kdetv with several channels i've configured with other card 
and I got a large series of

X Error: BadShmSeg (invalid shared segment parameter) 163
   Major opcode:  139
   Minor opcode:  19

in console..

I give up trying radio programs as there's no /dev/radio* created


BTW, the make reload freezes at
/sbin/insmod ./pms.ko
I had to reboot and let the drivers load themselves.

Desperate yours... :-o  :-)

Emilio Castellano Leiva

More information about the linux-dvb mailing list