[linux-dvb] saa7146_i2c_writeout: timed out waiting for end of xfer

André Weidemann Andre.Weidemann at web.de
Sat Aug 11 10:50:03 CEST 2007

Oliver Endriss wrote:
> Sigmund Augdal wrote:
>> On Tuesday 17 July 2007 07:45, Oliver Endriss wrote:
>>> Oliver Endriss wrote:
>>>> Imho the interrupt processing was broken:
>>>> - The first I2C interrupt should be used to wake-up the task.
>>>>   It does not matter that it takes some time until ERR in IIC_STA
>>>>   will be updated. We don't need it.
>>>> - Interrupts must be acknowledged at the end of the ISR.
>>>> @all
>>>> Please test the attached patch.
>>>> There shouldn't be any unexpected I2C interrupts anymore.
>>> Attached is an updated patch which does extended status checking.
>> I've tried this patch on a box running 2.6.20 now for about a day and has not 
>> yet seen any i2c timeouts with it. I have tried to stress the i2c bus a bit 
>> by starting and stopping capture, retuning and browsing the MMI menus of the 
>> CAM quite a lot. I did however not see any pattern in when the i2c timeouts 
>> happened before applying the patch, so I can't possitivly confirm they are 
>> all gone.
> Ok, patch committed with minor modifications.
> CU
> Oliver

Hi Oliver,
I just had time to read the mailing list after several weeks and 
stumbled accross this thread.

I have this error: "saa7146_i2c_writeout: timed out waiting for end of 
This error occurs with and without the patch, but only on my modded FF 
Card(TT1500 DVB-S) with 4MB. Any other card works flawlessly in the same 
comp and the very same PCI slot. I have two other TT1600 DVB-s which are 
not modded and working just fine.

Could the problems be caused by the 4MB-Mod?

Have nice weekend.

More information about the linux-dvb mailing list