[linux-dvb] m920x device: Genius TVGo DVB-T02Q

Aapo Tahkola aet at rasterburn.org
Sun Dec 2 21:38:07 CET 2007

On Sun, 2 Dec 2007 14:14:27 +0100
"Román" <roman.pena.perez at gmail.com> wrote:

>   Hi, Aapo, It's nice to hear from you ;-)

Nice to hear from you too. And nice to see this device is about to see
the daylight!

> 2007/12/2, Aapo Tahkola <aet at rasterburn.org>:
> > Hi,
> >
> > Here are some tips that might help:
> > - check that endpoint, buffersize and type match "lsusb -v" output
> > and usbsnoop logs if you are not sure what endpoint is being used
> (...)
> > If none of this helps, there might be some problem with zl10353
> > sending data to m9206. You can also use
> > "cat /dev/dvb/adapter0/dvr0" to do quick checks.
> >
>   I though the problem was what you said on your last point: cat
> /dev/dvb/adapter0/dvr0 gives no byte, so usbsnoop and such are useless
> tools at this point. Anyway I've tried them, but they gave me no
> results.
>   On the other side, I'm embarrassed because I never thought of
> running "lsusb -v" again, after the firmware was uploaded :-$. Thanks
> for the tip! Below you'll find the result of that command. Correct me
> if I'm wrong, but the problem might be I'm configuring the device for
> bulk transfers, when it wants to do isochronous ones (also, what about
> *MaxPacketSize* values?). Il try to play a little with that and post
> the results...

You are correct.
These parameters worked for me back in the days megasky used firmware
with isoc transfer mode:
		.stream = {
			.type = USB_ISOC,
			.count = 8,
			.endpoint = 0x81,
			.u = {
				.isoc = {
					.framesperurb = 1,
					.framesize = 564,
					.interval = 1,

You should know that m9206 isochronous mode might not play well with
some usb host controllers(VIA). I such cases you should be able to get
it working by removing ehci_hcd module before plugging your device. This
should disable usb 2.0 support in most systems. usb 1.0 hub
or even 2.0 hub might also help. You could also test this just to make
sure the pid filters are working correctly.

Aapo Tahkola

More information about the linux-dvb mailing list