[linux-dvb] Twinhan VP1041 and 64-bit FC6 troubles

Hans Werner HWerner4 at gmx.de
Mon Dec 10 17:32:19 CET 2007

thanks, I have tried your second patch from 
and could successfully see one dvb-s channel on my Twinhan VP-1041, but when I use szap -r to view the channel it hangs in a way that I can't kill (it becomes a process in state D, i.e. uninterruptible sleep). So I can't 
change channels and have to reboot. I didn't try dvb-s2 yet.

Here is what I did -- perhaps you can see something wrong:

a)kernel 2.6.20 stock ubuntu feisty, amd-64bit

b)used your patch to patch multiproto commit 0f3e5ce65e32

c)there was one file missing from your patch (cu1216_regs.h) so I copied it from the driver on twinhan's website v1.4.2

d)compiled patched multiproto and installed successfully

e)obtained scan from http://jusst.de/manu/scan.tar.bz2 and slotted in the util/scan directory of hg http://linuxtv.org/hg/dvb-apps/. I fixed up the .h includes to come from the earlier multiproto compilation.

f)obtained szap.c from http://abraham.manu.googlepages.com/szap.c and compiled it in util/szap according to

(messy -- is there a "dvb-apps for multiproto" tree somewhere?)

scan seems to work fine to create a channels.conf.
Then to view a channel I did:
szap -r -a 0 -l UNIVERSAL -t 0 -c channels.conf "channelname"
and then
mplayer - < /dev/dvb/adapter0/dvr0

szap tunes and locks and I get video and audio from mplayer but after that I cannot kill it (with ctrl-c or kill) to change to another channel.

Any idea what's wrong?
What's the best way to view channels?
Are you merging your code into multiproto?


> hy,
> i have updated my patch. now it's also based on the current mantis tree on 
> jusst.de (much improved i2c code, so intialization & tunning is much faster)
> http://pansy.at/gernot/twinhan-vp1041-2.diff.gz
> gernot
> On Monday 12 November 2007 13:54:27 Gernot Pansy wrote:
>> hy,
>> pherhaps you like to try this patch against the current multiproto branch
>> on http://jusst.de/hg/multiproto/.
>> http://pansy.at/gernot/twinhan-vp1041.diff.gz
>> it's working much better for me. also it compiles with recent kernels.
>> gernot
>> p.s.:
>> if you want to test it mythtv, youd could try this hack against current
>> svn:
>> http://pansy.at/gernot/mythtv-multiproto-hack.diff.gz
>> On Saturday 06 October 2007 19:16:57 Simeon Simeonov wrote:
>> > Hello everyone,
>> >
>> > I have hard time getting the VP1041 (Azureware AD-SP
>> > 400)
>> > to work properly with 64-bit FC6. I used the drivers
>> > from
>> > Twinhan web site. First compiled them with the stock
>> > kernel-2.6.18-1.2798, then I tried with the latest
>> > 2.6.22 -2 FC6 kernel. The drivers compile OK. They
>> > also load just fine, the frontend is created and all
>> > of the nodes in /dev/dvb* are created just fine.
>> > The problem is when I try to use the interface - as
>> > soon as I try to open the frontend I get kernel Oops.
>> > It looks like stb0899 module is not happy about
>> > something.
>> > I've seen that some people are using the card - how
>> > did you guys get it to work? Could it be the 64-bit
>> > that is giving me problems?
>> >
>> > Thanks.
>> > Simeon
>> >
Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen! 
Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer

Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger

More information about the linux-dvb mailing list