[linux-dvb] hauppauge nova-t stick driver problem... driver hacking?

José Oliver Segura primijos at gmail.com
Wed Dec 19 21:20:04 CET 2007

Hi all,

I've a recurring problem with an hauppauge wintv nova-t-stick that
*seemed* to be "solved" (see
or, actually, "assumed" (I assumed that some channels didn't have
enough signal power or signal quality). But a recent upgrade of
kernel&drivers has made it appear again. The short description is that
it looks like the linuxtv drivers for the hauppauge wintv nova-t stick
(USB2.0) seems to suffer "degradation" as I zap between channels.

If I start watching a channel (any ot the ones that tune) it tunes OK
and I can see it without problems (no artifacts, ber=0, unc=0 with
femon, signal aprox 0x7a00/0x8a00). If As I zap channels (on different
mux), the number for ber/unc increases. At the third/four ("n") zap
(depending on the combination of channels), the values for ber/unc are
very high, and the image presents aftifacts/sound glitches or is
frozen (I've not tested if there is a point at which it won't tune).
If, then (with a bad/frozen image), I rmmod dvb_usb_dib0700 and unplug
and plug de device and I try to tune again the same channel, it works
OK. Look at the numbers below (femon output):

at this point (after 4-5 channel zapping), the image is full of
artifacts or frozen (see ber/unc values):

status SCVYL | signal 7e05 | snr 0000 | ber 000405e0 | unc 00000122 |
status SCVYL | signal 7e1d | snr 0000 | ber 000319a0 | unc 000000ac |
status SCVYL | signal 7e15 | snr 0000 | ber 00031970 | unc 00000131 |

After unplug/plug of the USB (perfect image/sound):

status SCVYL | signal 77ef | snr 0000 | ber 00000000 | unc 00000000 |
status SCVYL | signal 77fa | snr 0000 | ber 00000000 | unc 00000000 |
status SCVYL | signal 77f3 | snr 0000 | ber 00000000 | unc 00000000 |
status SCVYL | signal 77e2 | snr 0000 | ber 00000000 | unc 00000000 |

I've tried this with the latest drivers (and kernel,
and with differents firmware files (dvb-usb-dib0700-[01 | 02-rc1 |
03-pre1 | 1.10], and the results are more or less the same (with some
of them, I get lot of errors from the driver complainig about the
RC,which was not supported in earlier firmwares, no problem)

I'm wondering if anybody knows a solution for this behaviour... if
not: can anybody point me (give me some directions) about implementing
a hack in order to do a "fake reload" of the module and/or a
"reinitialization" of the stick in each channel zap? Since this
problem seems not to be solved (or has reapeared, since I've had my
stick working for almost a year), I'm thinking about writing this
(quick, I know) hack in order to be able to watch TV :-(

Any help would be wellcome. If anybody needs some more data/debug/etc
in order to take a look, I'll be happy to provide it


More information about the linux-dvb mailing list